96 mb e300 dw starting problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-21-2009, 03:51 PM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 96 mb e300 dw starting problems

I am new to the forum and have just got a 96 mb e300dw, and love it when it works.

I was instructed by the dealer that after inserting the key and turning it into position 2, the preglow light is on. I have to wait for the light off, then I can start the engine for a cold start. But for quite a few times, when the preglow light is on, at the same time, the red indicator lamp (locking) and green indicator lamp (unlocking) under inner rearview mirror are both blinking. When this happens, the engine can't start. This past Saturday, I did follow the above procedure but both red and green lights under the rearview mirrow were blinking again. As expected, the car can't start. Then I waited for another one to two hours before restarting, and luckily it started finally. I have learnt from a car forum that while red and green lights blinking simultaneously on inner rearview mirror, system will cut off fuel supply to engine, you will not be able to start engine at that time. This is by design as MB wants to make sure only the owners having correct keys and entering car legibly.

I am not sure mine is a case of something wrong, because I do follow the procedure above mentioned for a cold start. Because this is a 96 car, the dealer didn't sell any warranty to me. So I am here to ask for help.

Thanks a lot!
96mbe300 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    97 E300 D radio problems vasilf1 W210 E-Class 5 09-12-2011 07:53 PM
    E300 TD Starting Issues kellyseals W210 E-Class 9 01-21-2009 12:55 PM
    Stored 1993 S420 has fuel problems-Gives sudden starting problems-solution needed heartmd W140 S-Class 15 12-09-2007 01:45 PM
    1996 E300 Diesel - Intermittent Starting Trouble. trainfriend W210 E-Class 4 11-03-2007 03:00 PM
    anyone have starting problems? My car died twice today after starting... cgeorge430 W163 M-Class 10 08-03-2002 10:57 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome