C230 Alarm goes off for no reason, wont stop - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-11-2009, 02:52 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
C230 Alarm goes off for no reason, wont stop

I purchased my C230 new from the dealership in 2003 and have had absolutely no problems with this issue until now.

about a week ago the alarm just went off for no reason, no lights blinking , just alarm, and putting the key in the ignition or pushing the panic button (both recommended in the manual) had no effect...car would start and unlock the whole time this was happening

after a couple (loud) minutes it stopped...but then went on again about a half hour later, but only for a few seconds...then again for 20 seconds but with kind of weak garbled chirping alarm sound...and once the stopping SEEMED to coincide with the opening of the door, or the placement in the ignition

then nothing for about a week...until tonight (at 2 am)...alarm went off for full 2 minutes or so, nothing would stop it (again no light blinking, just alarm)...the again about 2 hours later for 2 minutes or so...and then about 40 minutes later for 20 seconds but stopped when I opend the door...then again twice more in about 10 minutes.

Is there something I can do to overide the alarm, or at least stop it when it goes off?...what (other than just "take it to the dealer") can be done to either fix it or prevent it from taking place.

...or if need be, is there a way to turn off the alarm altogether?

what could be the cause of this?

a few days before a friend did run a diagnostic test on it, not sure if that would be related.

Any input or insight would be great!
Danetanamo is offline  
Sponsored Links
post #2 of 4 (permalink) Old 09-11-2009, 11:22 AM
Supporting Vendor
FCP Euro's Avatar
Date registered: Jul 2008
Posts: 647
Mentioned: 0 Post(s)
Quoted: 22 Post(s)
Welcome to the Board. 6 years without any real issues is a great run. I would post these issues in the repair section. You will get a response mush faster there.

Quality & Service, Guaranteed for Life
FCP Euro - OEM & Genuine European Auto Parts Online
FCP Euro is offline  
post #3 of 4 (permalink) Old 09-11-2009, 11:36 AM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
post #4 of 4 (permalink) Old 09-12-2009, 02:37 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you for the welcome and the insight!

Thank you again and yes, I have posted there as well and hope to get some help...hate to jinx it but all day friday and tonight so far have been screechy-alarm free.

have a great weekend!
Danetanamo is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Alarm Goes off for no reason! mr cracker W163 M-Class 6 01-25-2013 10:45 PM
    99 SLK: Alarm going off for no reason?? cdalesch R170 SLK-Class 2 06-27-2008 02:30 PM
    My Alarm wont stop! g2blkemike W126 S,SE,SEC,SEL,SD,SDL Class 1 03-27-2006 08:56 AM
    Car alarm goes off for no reason E-Klasse R170 SLK-Class 4 07-10-2005 07:40 AM
    PLEASE HELP, ALARM GOES OFF FOR NO REASON!!! chona W163 M-Class 2 03-15-2005 08:29 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome