If I am not posting in the right place let me know, I'm a newbie - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 09-10-2009, 06:27 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
If I am not posting in the right place let me know, I'm a newbie

I have owned BMW's for years, my daughter has one , my husband had one and I did. Recently we went into another direction. I saw a cute little ml320 a 1999.Bought it on the spot. Liked it because all the seats went down and i could fit all my horse equipment in it. With getting 23 miles to a gallon it is great. Where my truck gets 9. Anyway. Like any new relationship we had a little bit of a rough start. And I mean start. I had it for a month then all of a sudden it went into limp mode and I drove 5 miles like that ..LOL. After many many replacement parts it was the fuel pump.We have a code reader that covers this car also. It was pulling a lot of different codes and we did find alot of leaks in the hoses, dry rot.Replaced a couple BIG parts also..NOT good but I am sure they would have had to be replaced soon also. But then the fuel pump was it in the end. Even though the code reader did not bring it up.. Now about 3 months later I put the key in and it cranks( with a spark) but doesn't start. I turn the key off and try again and it starts.This is ALL the time. Never any different. Took it to the mechanic after 2 months of this that put the fuel pump in and he said he can't figure it out.He said no codes coming up and the fuel pump is working. So, without a chilton book ( i can't find one on this car) I started at the most likely in my limited Mercedes mind. I put new batteries in the remote key(which i have only one , yikes I know) it wasn't that. I don't know if the chip in the key can do this. Never had a problem with my BMW like this.The battery looks pretty beat and thought hummm well maybe that. Not that. The mechanic said it was not the starter. It does this all the time. If you turn the car off after driving it, it will start right up. Wait 15 minutes and it's the 2 key turn on again. So when it's hot it starts right up. I am wondering if it's a relay for the fuel pump. Is there one or 2 relays and where are they located. Any help would be greatly appreciated.I am a babe in the woods with this car. I'm pretty good at checking stuff and if I have a book can follow ideas and go with it, but with not being able to get a book it's hard.Growing up with 3 brothers has taught me to learn and try to eliminate the easy stuff. Sorry for the long post and sorry if I posted in the wrong place or did something wrong. Just let me know.I have a feeling I will be on here alot..LOL..I do love the thing...
pjohnston911 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 09-10-2009, 06:37 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,590
Mentioned: 3 Post(s)
Quoted: 311 Post(s)
Try asking your questions on the W163 forum, your car is a W163 so they are the people to help you.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is online now  
post #3 of 10 (permalink) Old 09-10-2009, 06:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I'll attempt that...I'm not a regular user of sites ..It took me about 20 minutes to get registered. Kept getting the verifications box wrong..Thanks.
pjohnston911 is offline  
 
post #4 of 10 (permalink) Old 09-10-2009, 07:11 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,590
Mentioned: 3 Post(s)
Quoted: 311 Post(s)
Quote:
Originally Posted by pjohnston911 View Post
I'll attempt that...I'm not a regular user of sites ..It took me about 20 minutes to get registered. Kept getting the verifications box wrong..Thanks.
At the bottom of the screen page you will find this. Forum Jump, use this to find the W163 forum and start a New Thread there. If you find more problems let me know.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is online now  
post #5 of 10 (permalink) Old 09-10-2009, 10:53 AM
Supporting Vendor
 
FCP Euro's Avatar
 
Date registered: Jul 2008
Posts: 738
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Welcome to the forum. I know how the verification box can be a pain. But you are here now so we will try and get her running for you. I would still do what Eric said and post in the W163 section.


Quality & Service, Guaranteed for Life
FCP Euro - OEM & Genuine European Auto Parts Online
FCP Euro is offline  
post #6 of 10 (permalink) Old 09-10-2009, 10:56 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,590
Mentioned: 3 Post(s)
Quoted: 311 Post(s)
Quote:
Originally Posted by FCPGroton View Post
Welcome to the forum. I know how the verification box can be a pain. But you are here now so we will try and get her running for you. I would still do what Eric said and post in the W163 section.
Better late than never

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is online now  
post #7 of 10 (permalink) Old 09-10-2009, 11:29 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Everyone
pjohnston911 is offline  
post #8 of 10 (permalink) Old 09-10-2009, 02:23 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 210,xxx Miles
Posts: 7,685
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
leapyfish is offline  
post #9 of 10 (permalink) Old 12-23-2009, 08:01 AM
BenzWorld Junior Member
 
Date registered: Nov 2009
Vehicle: 82 380SL 98 ML320 01 ML430 86 560SEL convertible! 77 450SEL
Location: Cedar Rapids, IA
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to nucaro
Do you leave your key in the ignition in the garage? If so, it is the security system that thinks someone is stealing the car. If you want to leave it in, after you park, pull the key out (until you hear the "click" and put it back in. Probably will solve your issue. If you are not leaving the key in, it is probably a faulty/intermittent ignition switch.
nucaro is offline  
post #10 of 10 (permalink) Old 12-23-2009, 08:22 AM
BenzWorld Junior Member
 
vSID's Avatar
 
Date registered: Dec 2009
Vehicle: CLK 350
Location: Dallas,TX
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I can relate.. first car was BMW then I bought the MB and everything went downhill.
vSID is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Posting??? Josh R C208/A208 CLK-Class 6 08-27-2015 09:01 AM
help in posting dugald R/C107 SL/SLC Class 9 05-12-2008 01:10 PM
posting tmoger Unimog 4 06-24-2006 02:44 PM
Newbie>Hello>>Where is the best place in Germany to buy Hi-Performane add on parts for my SLK32 YianniSLK32 R170 SLK-Class 17 09-24-2005 02:08 AM
Where is the best place to get a carbon fiber steering wheel? Cheapest place..... SilverSport R170 SLK-Class 1 01-12-2002 07:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome