S 600 Sedan transmission problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-07-2009, 07:11 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2007
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S 600 Sedan transmission problem

Hi Guys,

I bought this S600 nearly 4 years ago with 86000 miles on it. On rare occasions, the transmission would do a delayed down shift, hitting hard when the shift occurs. I think it was shifting from 3rd or 4th down to 2nd. It didn't happen but about once in 6 months. Other than this problem it is perfect in every way.

Now with 115,000 miles the problem has gotten worse. The 2-3 upshift is a little delayed and harsh. The down shift under full throttle at speeds over about 40 mph are real hard-the wheel spin light comes on momentarily.

I've had it to the MB dealer twice; they say that there are no codes being set; think the trouble is internal. Cost of them rebuilding is about $7000.00.

I talked with a couple of transmission shops and they wonder since this is the 5 speed computerised tansmission, that it may have a solenoid problem that is giving the problem.

Question; I hate the expense and if it is a small solenoid problem; why does the whole transmission have to be rebuilt when it has worked well for the last 4 years.

What do you think?
John Logsdon is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-07-2009, 07:46 PM
BenzWorld Member
 
Date registered: Apr 2009
Vehicle: 1999 E300TD
Location: PA
Posts: 167
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
John, it does sound like a solenoid problem and without any codes being set it can be hard to diagnose. They also have a lot of problems with the valvebody, which is basically the brains of the transmission. From my experience if the fluid is in ok condition and not completely burned up I would replace the entire valvebody which will come with the electrical plate (all of the solenoids are included with the plate). The valvebody will run you approx 1400 i think plus a few hours labor. Also make sure you check the transmission module to make sure there is no fluid in it . The fluid can actually get sucked up through the wiring and damage the module . If I remember it is located under the carpet of the front passenger.
saleen1276 is offline  
post #3 of 3 (permalink) Old 09-08-2009, 07:22 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2007
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S600 transmission problem

Saleen, thanks for your reply.

The suggestions you made make sense. I will start down that road.\

Thanks, John
John Logsdon is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    722-600 transmission timlock W210 E-Class 5 10-05-2014 05:52 AM
    1966 600 Series Automatic Transmission Problem wawoola Vintage Mercedes-Benz 3 03-01-2008 09:10 AM
    1978 Mercedes 300D diesel sedan - $600 P4olom W123 E,CE,D,CD,TD,TE Class 6 04-03-2007 08:47 PM
    For Sale: Used Mercedes 1960s Automatic Transmission - GOOD SHAPE - $600 ameister For Sale/Wanted/Trade/Giveaway 0 07-16-2006 01:30 PM
    SL 600 ADS problem lowanover R129 SL-Class 3 09-20-2003 03:34 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome