SRS airbag light on - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 09-07-2009, 07:57 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
SRS airbag light on

I own a 2004 C240 4 matic with 57,000 miles on it.The srs light went on,and the message said drive to workshop now!Its labor day weekend here in the states and i was on my way to the lake. I figured the airbag systym would just shutoff if i kept driving(taking a chance i know).Well the light is still on and at 1 point the cd player stopped working,it said on the dash "no cd player".The next day the cd player worked but the automatic window function would not work when i pushed for the windows to go up.Later 2 of the windows did go up automatically but the other 2 didnt.Never had these problems until the srs light came on.Also i should mention that before the light came on sometimes when i pushed the up or down button on the steering wheel the horn would blow.Ever since i bought the car when i kept my finger on the + button on the steering wheel to raise the volume on the radio the horn would blow.Im not sure but im thinking there might be a problem in the steering wheel.Any thoughts or ideas would greatly be appreciated.
speddy is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 09-07-2009, 11:20 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
On the surface these symptoms appear unrelated but they probably are not. One thing you can check is the battery. Low batteries can cause all sorts of odd electrically related things.

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 09-07-2009 at 11:35 AM.
Musikmann is offline  
post #3 of 14 (permalink) Old 09-08-2009, 05:45 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I checked the battery,it checked out fine.I replaced it anyways.It is about 6 years old.I figured it was gonna go soon anyways.I still have the original problem.Any other thoughts or ideas?
speddy is offline  
post #4 of 14 (permalink) Old 09-08-2009, 07:10 PM
imo
BenzWorld Member
 
Date registered: Dec 2008
Posts: 85
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
according to repair pal website
for year and model.
* Brake light switch failure can cause the ESP and BAS warnings to illuminate.
* A bad seat control module can cause a dead battery. Spilling liquid on the front seats can cause these modules to fail.
* CD changers suffer from internal mechanical problems and may need replacement.
* The SRS (airbag) light may illuminate if liquid is spilled into the seat belt buckles or pools underneath the seat and gets into the electrical connector for the seat belt pretensioners.
I think it may be related to some kind of short or intermittent connection.
imo is offline  
post #5 of 14 (permalink) Old 09-08-2009, 08:16 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
I think I would also start a thread on the W203 forum so you capture the attention of some other actual owners. Whoever sees your thread here is hit or miss. I own a different car and the other poster probably does too. Back to your problems now.

SRS Light could also be due to a bad weight sensing pad in the passenger seat. It's purpose is to sense the weight of the person sitting there. If under about 60 lb it inactivates the airbag.

CD player/changer is one of the components that are connected to others in the D2B fiberoptic loop. If it is not recognised by the car, it can malfunction. If this is the problem it will take a dealer, or someone else with the Star diagnostic system to code it into the car's system.

Windows might be due to liquid having been spilled around the master switches. At least on my car, they are connected together on a single circuit board and under the center console.

Horn might have something to do with the steering wheel since that's the only place I know of to activate it (make it blow). I have never had one apart so I don't know how close the +/- button wires are to those involved with the horn.

One last thing is your car has a CAN/BUS system that links certain components together. I don't understand it at all but it has been blamed for any number of strange electrical-type problems like with the bad battery I mentioned earlier.

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 09-09-2009 at 07:15 AM.
Musikmann is offline  
post #6 of 14 (permalink) Old 09-09-2009, 03:44 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I bit the bullet and took my car to the shop.It turns out it was the battery.The voltage was off on everything that was out of wack and set codes off.They reset the srs, reprogrammed the windows and cleared all the other codes.The car seems fine now.Hopefully it stays that way!
speddy is offline  
post #7 of 14 (permalink) Old 09-09-2009, 05:46 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
But you told us you replaced the battery, I don't understand?

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #8 of 14 (permalink) Old 09-09-2009, 05:52 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Musikmann View Post
But you told us you replaced the battery, I don't understand?
I did replace the battery,but apparently the old battery screwed everything up.Once things go out of wack they stay that way until they are reset or reprogammed with the garages scanner.
speddy is offline  
post #9 of 14 (permalink) Old 09-09-2009, 05:57 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by speddy View Post
I did replace the battery,but apparently the old battery screwed everything up.Once things go out of wack they stay that way until they are reset or reprogammed with the garages scanner.
I see now, thanks for explaining. In other words there were a lot of stored error codes that had to be cleared.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #10 of 14 (permalink) Old 09-09-2009, 06:01 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Yea exactly.Some things also needed to be reprogrammed.I drove the car for about 2 hours since the garage did that and its been fine so far.(Knock on wood).I hope it stays fixed lol.
speddy is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    560SL airbag/SRS light sokoloff R/C107 SL/SLC Class 20 08-31-2015 05:55 PM
    SRS + Pass AirBag Off Light mlx52 W163 M-Class 5 08-03-2010 03:54 AM
    SRS and Airbag light almost always on ALT W210 E-Class 3 09-01-2007 03:57 AM
    SRS/Airbag Light dmico2 W163 M-Class 6 08-18-2005 11:16 PM
    SRS (AIrbag) light on huapi23 W163 M-Class 2 04-10-2005 09:35 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome