03 C240 Windshield wiper problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-06-2009, 08:24 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Vehicle: 03 C240 4matic
Location: washington
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile 03 C240 Windshield wiper problems

I have an 03 C240 4matic and my blinkers, turn signals, cruse control, and horn just stopped working. any suggestion's. The fuse's look fine. Someone told me it could be a relay. If so, which one.

drucoppernoll is offline  
Sponsored Links
post #2 of 4 (permalink) Old 09-06-2009, 09:40 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
You have what Daimler calls a W203 C-Class and there is a forum devoted to those. Scroll down from here (General Mercedes-Benz) until you find the MB Sedans section. You should see the W203 forum. Then ask your question there where most of the W203 owners hang out. I'm sure someone will be able to help you. Good luck.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 4 (permalink) Old 09-08-2009, 01:11 AM
BenzWorld Member
Date registered: Sep 2009
Posts: 50
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
U can take it to the mechanic. He might help u with that.
team.work is offline  
post #4 of 4 (permalink) Old 09-24-2009, 01:20 PM
BenzWorld Junior Member
JaredMBClinic's Avatar
Date registered: Sep 2009
Vehicle: 1998 C240
Location: Denver, Co
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Sounds like either your combo switch is bad (switch with wipers, blinkers etc..) or there is a little disc behind the steering wheel that all of that connects to that sometimes goes bad. requires removal of the steering wheeland air bag. i recommend taking to a MB shop or dealer
JaredMBClinic is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Windshield Wiper Linkage problems thebosshog W123 E,CE,D,CD,TD,TE Class 4 08-29-2008 05:58 PM
    Windshield Wiper Problems jordanhoff W201 190-Class 6 03-10-2008 06:28 AM
    Windshield Wiper Problems gus_carrero C208/A208 CLK-Class 1 06-28-2007 07:58 AM
    Windshield wiper problems BostonBob W251 R-Class 0 02-25-2007 08:45 AM
    2003 C240, windshield wiper long plastic part, passenger side doesn't have it?? djdragan W203 C-Class 3 08-02-2003 02:50 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome