87 420SEL Transmission Issues - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-04-2009, 07:33 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Vehicle: 1987 420 SEL
Location: Oklahoma City, OK
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
87 420SEL Transmission Issues

I have a 87 420 SEL with automatic transmission. It has developed a problem when driving. When in drive it goes fine for a bit then it seems to just drop out of gear and the engine just revs as in neutral. If you shift down to 3rd then it kicks back in and runs fine but won't shift up to the final drive. If you start out with it set for 3rd it runs fine, but still won't shift above 3rd of course. I'm would like to know what I should check and in what order. I have topped up the ATF fluid level and am in the process of checking for leaks. Thanks for any info you can pass my way.

okcraig is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Transmission issues (1990 300E, 3.0L, 722.5 transmission) Eric@StarSuzuki W124 E,CE,D,TD Class 5 04-13-2011 07:29 PM
    89 420sel transmission problems benz_man101 W126 S,SE,SEC,SEL,SD,SDL Class 6 05-26-2009 09:06 PM
    420SEL transmission in a 300SEL? Extrordnry25 W126 S,SE,SEC,SEL,SD,SDL Class 3 05-25-2009 11:48 PM
    420sel air issues? Qxztryl W126 S,SE,SEC,SEL,SD,SDL Class 6 08-19-2008 08:28 AM
    88 420SEL transmission problem william.wood W126 S,SE,SEC,SEL,SD,SDL Class 1 03-03-2006 01:54 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome