Check Engine Light and Techron solution - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-17-2009, 02:26 PM
BenzWorld Member
 
abiazis's Avatar
 
Date registered: Jul 2009
Vehicle: 2005 silver/black SL 65 AMG
Location: Asheville NC
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Talking Check Engine Light and Techron solution

Amazing.....I have had three different cars that had the CEL stay on and had it turn off after running a minimum of a bottle of Techron fuel injector cleaner and then a bottle of Techron fuel system cleaner, consecutively, if necessary. Like clockwork, don't think it was a coincidence......must do the necessary cleaning in just the right way or I am just a lucky SOB.....never had the lights return on any of these cars...

Cars involved:

2000 BMW E39 M5 - 55K miles driven
2003 Porsche C4S - 81K
2005 SL65 AMG - 27k driven

Anyone similar experience??
abiazis is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-17-2009, 02:40 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 2001 E55 AMG, 2001 ML320, 1984 500SE AMG
Location: Swartz Creek, MI
Posts: 4,705
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The next time your CEL comes on, have the codes read. Advance Auto or Autozone can do it. Better to figure out what is going on with your cars that just running the cleaner. You might need something else. If you post the codes, I am sure someone here can help you figure out what is going on.

Mike
Michael Pillay is offline  
#3 (permalink) Old 08-17-2009, 05:43 PM
BenzWorld Member
 
abiazis's Avatar
 
Date registered: Jul 2009
Vehicle: 2005 silver/black SL 65 AMG
Location: Asheville NC
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the advice on getting the codes read...I will..

I usually use Techron 3 times a year and have not had the CEL in any of the cars go on again after that initial time, unless a catalytic converter went bad (Porsche).

I wanted to see if anyone else with MB has had a similar experience.....it is interesting that 3 times in a row that adding the additive was the only thing I did before the lights went out, along with an "Italian tuneup" of blowing the car out at high speed for 3-5 minutes on a very safe no other cars road......

I will have to check the codes.....AutoZone - good idea...

Since the cars all run extremely fine using the stuff 3x a year, I will try to keep them out of the shop in the fear that a mechanic will mess them up, unless the codes indicate something more than a misfire, etc....
abiazis is offline  
#4 (permalink) Old 08-17-2009, 06:18 PM
BenzWorld Elite
 
Date registered: Dec 2008
Vehicle: w204 (C350ELE)
Location: Miami, Fl and Mar del Plata, Argentina
Posts: 1,262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation

Quote:
Originally Posted by abiazis View Post
I usually use Techron 3 times a year and have not had the CEL in any of the cars go on again after that initial time, unless a catalytic converter went bad (Porsche).
I wanted to see if anyone else with MB has had a similar experience.....it is interesting that 3 times in a row that adding the additive was the only thing I did before the lights went out, along with an "Italian tuneup" of blowing the car out at high speed for 3-5 minutes on a very safe no other cars road......
I will have to check the codes.....AutoZone - good idea...
Since the cars all run extremely fine using the stuff 3x a year, I will try to keep them out of the shop in the fear that a mechanic will mess them up, unless the codes indicate something more than a misfire, etc....
Hi Abiazis:

I'm neither a preacher nor a prude, just trying to give you an honest opinion which might render in your favor.

First, I'm a defender of Techron, and use the injector cleaner every 3000 miles followed with 6-8 gallons of gas. Also I make it a point of gassing up in an Oil Company Service Station of decent activity. This keeps, so far, my gas systems happy.

From what you say, it seems to me that you have dirty gas filters and the need to look at your exhaust recirculation systems. The Porsche converter problem seems to confirm this. Also the consistency of similar failures in your three cars points to the need for a revision of your maintenance schedules and/or mechanic. If you have not done it in the last 30000 miles, consider doing a professional injector cleaning and fine tuning of the ignition and fuel systems. But make sure you get it done at a place that is worth it. Meanwhile, finding out the codes should be a good orientation in the right direction.

Cheers, JV
JoeVal is offline  
#5 (permalink) Old 08-17-2009, 07:54 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 104,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
I add a 20 oz bottle of Techron every 3000 miles as they recommend. I also only use Chevron Supreme 93 octane. I have never had a CEL and wonder if that is the reason. I did not realize there was more than one version of Techron. Fuel injector and fuel system cleaner? Where do you find those?

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
#6 (permalink) Old 08-18-2009, 07:04 AM
BenzWorld Member
 
abiazis's Avatar
 
Date registered: Jul 2009
Vehicle: 2005 silver/black SL 65 AMG
Location: Asheville NC
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
techron - auto store availability

I have found techron fuel injector cleaner (20 gallon treatment) and their fuel system cleaner(12 gallon treatment) at autozone, pep boys and advanced auto parts....i believe you can find these products in most auto parts stores....they really work in my opinion and experience as cars seem to idle smoother, etc....besides helping with CEL for me at least....
abiazis is offline  
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2002 c 230 check engine light and srs light upstaterider2003 General Mercedes-Benz 4 08-04-2008 07:35 AM
techron Additive + chevron full tank = CHECK Engine Light, and very poor behavior?!? sightless R170 SLK Class 15 02-12-2008 02:51 PM
1997 S420 Fuel gage light flasehs setting Check Engine light aljabari W140 S-Class 7 09-03-2007 09:19 PM
How to check code for check engine light 94 E320 W124 Synd W124 E,CE,D,TD Class 1 05-24-2007 02:37 PM
check engine light & flashing fuel guage light pd99sl500 R129 SL Class 7 02-27-2005 04:31 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome