300SD coolant pump housing problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-14-2009, 07:39 PM Thread Starter
BenzWorld Junior Member
Date registered: Aug 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
300SD coolant pump housing problem

I have a 1984 300SD and the coolant pump housing seal is driving me mad. I have replaced it 3 times with and without permatex and it still leaks.

I noticed a small hole below the housing but I never removed a bolt. Not sure why it is there and I don't think this is where my leak is.

scamandin is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    WTB: Central lock pump & Close assist pump 4 1992 300sd Megadiesel For Sale/Wanted/Trade/Giveaway 0 02-12-2009 07:09 PM
    1980 300SD vacuum pump problem Jim x 3 W116 S, SE, SEL, SD Class 3 07-04-2008 07:56 AM
    water pump housing bolt cashman W123 E,CE,D,CD,TD,TE Class 0 08-23-2006 09:45 PM
    torque values for water pump and thermostat housing ggenovez Vintage Mercedes-Benz 0 10-22-2005 08:07 PM
    last bolt on water pump housing TMN G-Class 3 10-29-2001 03:54 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome