2009 ML350 CHECK ENGINE LIGHT HELP 2500 MILES NEW - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-14-2009, 02:17 AM
BenzWorld Newbie
 
Date registered: Aug 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2009 ML350 CHECK ENGINE LIGHT HELP 2500 MILES NEW

I had a check yellow engine light on in my ML350 suv for 8 days and was told that it could be the gas cap which was already very tight, but I made sure to tighten it and the light did not got off within three days, so I took it into the dealership. It went off the second I arrived at the dealership, but they still said they ran a check and came back with that it was most likely the gas cap, nut the car was fine.

Well, since then I have not filled up any gas it has been a week and the Check Engine light is back on in Yellow. Called dealership for what they thought and said they don't have any idea, but the code for the last time I was there was 1025 which is an evaporation leak, but was told that the level was low, so there was no leak of any kind and that is why they previously thought the light was caused by the gas cap. Not sure what that means. Any help would be great. The car has only 2500 miles.
RickiB is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-03-2009, 07:28 PM
BenzWorld Junior Member
 
Date registered: Jul 2009
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
options are purge valve, gas cap or fuel tank, the dealership should be able to figure it out until its fixed, dont give up, DONT TAKE THE CAR BACK UNTIL THEY FIX IT, YOU ARE STILL UNDER WARRANTY
c55amgwrench is offline  
#3 (permalink) Old 09-03-2009, 07:52 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 29,093
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Do you "top off" when you fill up? If so, stop doing that. It'll damage the evap system and trigger codes and the CEL.

Instead of just checking the cap, remove it, spin the gasket a bit, then reinstall.

But I agree with the other poster, the dealer needs to step up and take care of it for you.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
#4 (permalink) Old 09-03-2009, 10:03 PM
BenzWorld Member
 
unlukky's Avatar
 
Date registered: May 2007
Vehicle: 2006 CLS500
Location: Fort Worth, TX
Posts: 346
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Post

Greg-
My brother just bought a 2003 W211 (E500). He had driven for a day, then got the CEL with the code 0455 I believe (Large EVAP leak). I advised him to take off and reseat his gas cap. He did but CEL won't reset and fault still shows current. Any jumping off point I should have him look at. Is the code somehow non-resettable and he'll just have to make a few trips for the ECU to reset itself.
Thanks in advance,
John


--John
2006 CLS500
unlukky is offline  
#5 (permalink) Old 09-03-2009, 10:31 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 29,093
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
^^^ Hey, John. It's cruel to jack a newbie's thread, dood.

Most engine related codes are not hard-set and once the underlying issue is resolved, enough run cycles will clear the CEL (that's true of all the evap codes). Since we're already jacking the guy's thread, where in NorCal are you? If you're close to the bay area you should cruise the GTG in October, see the events section.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
#6 (permalink) Old 09-04-2009, 02:22 AM
BenzWorld Member
 
unlukky's Avatar
 
Date registered: May 2007
Vehicle: 2006 CLS500
Location: Fort Worth, TX
Posts: 346
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by gregs210 View Post
^^^ Hey, John. It's cruel to jack a newbie's thread, dood.

Most engine related codes are not hard-set and once the underlying issue is resolved, enough run cycles will clear the CEL (that's true of all the evap codes). Since we're already jacking the guy's thread, where in NorCal are you? If you're close to the bay area you should cruise the GTG in October, see the events section.
Wasnt trying to Jack the thread. Out of my element being away from the w208 board.

Sorry RickiB.
I live in Vacaville. I'll check it out.


--John
2006 CLS500
unlukky is offline  
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
6k miles and check engine/oil light didn't go on yet... jackie100 General Mercedes-Benz 26 03-09-2007 09:09 AM
83 Miles....Check Engine Light jakepratt R171 SLK Class 9 12-09-2004 12:10 AM
Check engine light came on at 4,210 miles.....what????? itswindee R170 SLK Class 11 10-15-2004 10:52 AM
Check engine light at 290 miles!! rkonster W163 M-Class 6 08-23-2004 10:02 PM
4k miles and this morning, the CHECK ENGINE light went on... elfkonig W163 M-Class 14 05-03-2003 12:07 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome