C230K 2003 fuel guage - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-05-2009, 06:14 PM Thread Starter
BenzWorld Junior Member
Date registered: Aug 2009
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Arrow C230K 2003 fuel guage

i have a 2003 C230K and my fuel gauge isn't working. it's on E but i know i have half a tank left. Can anyone suggest what to do.
it's been 3 days already
familyjoke is offline  
Sponsored Links
post #2 of 3 (permalink) Old 08-05-2009, 06:24 PM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Your car has a fuel level sending unit (sensor if you prefer) and it is somewhere in the fuel tank. On some cars this is a difficult job to replace, but I don't know about yours. Try asking about this on the W203 forum where the actual owners hang out.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 3 (permalink) Old 08-06-2009, 09:24 AM
Outstanding Contributor
keyhole's Avatar
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,358
Mentioned: 9 Post(s)
Quoted: 343 Post(s)
Originally Posted by familyjoke View Post
i have a 2003 C230K and my fuel gauge isn't working. it's on E but i know i have half a tank left. Can anyone suggest what to do.
it's been 3 days already
Keep your eye on the odometer and make sure that your tank is kept over half full, judging by your normal fuel consumption. Do you have a 'Range' display at the cluster?

Meanwhile get your codes read with an OBD2 reader. According to my files the tank level fault codes are these:

P0460 Fuel Level Sensor Circuit Malfunction
P0461 Fuel Level Sensor Circuit Range/Performance
P0462 Fuel Level Sensor Circuit Low Input
P0463 Fuel Level Sensor Circuit High Input

However, your C230K has a tank divided into 2 halves, each of which has a level sensor. I have no idea how you know which one has failed...

To reach them is no fun. To get access you must remove the rear seat & covers. Then unscrew a very large nut in the tank (special tool reqd here) before you can remove either sensor. Not a job for the faint-hearted!

Of course it might be a fault on your display. If they are plasma, there are stories of ribbon cable connector problems. Look up cluster faults in the archives using the 'search' facility ^^^.

Oh, and welcome to the forum. Use the UserCP ^^^ to include some details of your car and your location, as it sometimes helps. And as MM says above - you have a forum just for your MB model.
keyhole is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2003 C230 gas guage inop today! jj2828 W203 C-Class 10 08-10-2008 10:40 PM
    New fuel guage, does this seem right? Nascar Fan R/C107 SL/SLC Class 5 07-18-2007 05:21 PM
    fuel guage jonny5quest W123 E,CE,D,CD,TD,TE Class 1 06-30-2005 06:44 AM
    no movement on temp guage and fuel guage rr_havuz W202 C-Class 6 12-31-2003 07:12 PM
    Fuel guage... Guest (MBNZ) W203 C-Class 3 11-19-2001 03:43 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome