1997 E320 parked for 3 month, wont start - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-03-2009, 10:28 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1997 E320 parked for 3 month, wont start

The engine turns but will not start, I wanted to start with the basics, I dont believe I hear the fuel pump clicking. I am unable to locate the fuse for the pump, I ve tried locating it on the hood left and right side and the back seat panel box. Is there a special location for it? Anyone's help is appreciated..
gonziva is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-03-2009, 05:28 PM
BenzWorld Elite
 
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld, try posting this question in the W210 E class forum
livefreeordie is offline  
post #3 of 3 (permalink) Old 08-04-2009, 11:15 AM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    00 E320 wont start after engine warms up hellah fresh W210 E-Class 4 06-02-2009 10:23 PM
    00 E320 wont start after engine warms up hellah fresh W210 E50 AMG, E55 AMG 0 06-02-2009 09:53 AM
    1997 E320 won't start NELSON76 W210 E-Class 2 09-09-2008 07:56 PM
    My 1997 E420 wont start. 1997.E420 W210 E-Class 2 05-20-2008 04:34 PM
    E320 Wont Start on first try? EnduroE320 W210 E-Class 2 12-15-2007 05:14 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome