abs malfunction 1989 300e - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-01-2009, 08:26 AM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2004
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
abs malfunction 1989 300e

Hello,

I'm having an odd problem with the abs on my 89 300e.

It seems that whenever it has been raining or even when the humidity is high the abs warning light on the dash comes on and the engine is then very hard to start and reluctant to remain running. It almost feels like water in the gas--like the car will idle roughly but falters if you give it too much throttle.

Sometimes the abs light will go off, perhaps 10 seconds after the car starts and the engine then immediately runs smoothly. Other times the light will stay on and the engine will only run with just enough power to move the car until it is warmed up.

Usually once the engine is warmed up the light will go off and the engine starts running noticeably smoother and more powerfully. Occasionally the light will come on after the car has been driven and completely warmed up with little effect on the engine performance and then just as mysteriously goes off.

I replaced the abs pump last year because the circuit to the rear brakes was not working but don't remember if I was having the problem before the replacement--I think I had the problem with the last pump though. I saved the old pump and modules thinking that I might switch the modules to see if it made any difference.

The brakes seem to continue to operate properly while all this is going on but I have never tried to engage the abs with a panic stop to know if the pump itself is actually working properly.

Any comments or suggestions would be greatly appreciated.

Mike
mharness is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
ABS malfunction warning alex1234 G-Class 6 02-20-2015 05:36 AM
ABS malfunction firemon General Mercedes-Benz 1 07-15-2009 11:53 AM
300E ASR/ABS/Dealer says ABS Speed Sensor kasteveb W124 E,CE,D,TD Class 7 07-03-2009 06:39 AM
ESP-ABS-BAS Malfunction help please moaad001 W210 E-Class 16 03-18-2009 09:49 PM
abs malfunction light came on Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 1 08-08-2002 01:00 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome