Turn signal problem........ - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-27-2009, 03:20 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2009
Vehicle: 04 E320 Sport
Location: Atlanta, Ga
Posts: 32
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Turn signal problem........

On my 04 e320 the turn signals and emergency flashers work, but the indicators on the dash dont light up or blink. Anyone have any suggestions or comments on what the problem might be?.............Thanks in advance.


NoBrakes
nobrakes is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-30-2009, 08:49 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,687
Mentioned: 11 Post(s)
Quoted: 404 Post(s)
I wonder if this fault would show up if you had your codes read?
keyhole is offline  
post #3 of 7 (permalink) Old 07-30-2009, 09:07 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,583
Mentioned: 3 Post(s)
Quoted: 311 Post(s)
Quote:
Originally Posted by keyhole View Post
I wonder if this fault would show up if you had your codes read?
Yes it would, there will be a fault code stored on the front SAM.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
 
post #4 of 7 (permalink) Old 08-02-2009, 08:04 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2009
Vehicle: 04 E320 Sport
Location: Atlanta, Ga
Posts: 32
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
no trouble code is showing and "no malfunction " is displayed.

Nobrakes
nobrakes is offline  
post #5 of 7 (permalink) Old 08-02-2009, 08:22 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 213.050 & 906.633
Location: Europe
Posts: 10,342
Mentioned: 3 Post(s)
Quoted: 39 Post(s)
Quote:
Originally Posted by nobrakes View Post
no trouble code is showing and "no malfunction " is displayed.

Nobrakes
Do you mean codes or messages at the cluster or has the car been diagnosed with Star?
Diesel Benz is offline  
post #6 of 7 (permalink) Old 08-02-2009, 08:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2009
Vehicle: 04 E320 Sport
Location: Atlanta, Ga
Posts: 32
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I mean at the cluster.........
nobrakes is offline  
post #7 of 7 (permalink) Old 08-02-2009, 09:24 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,687
Mentioned: 11 Post(s)
Quoted: 404 Post(s)
Get thee to an OBD-11 code reader ....
keyhole is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Turn Signal Problem MercedesC220Car W202 C-Class 6 06-14-2012 01:07 PM
Turn Signal Problem Rainman66 W203 C-Class 4 07-11-2009 08:17 PM
Turn signal problem ADiaz W203 C-Class 4 03-18-2008 06:57 PM
Turn Signal Problem Michael Pillay W163 M-Class 2 10-13-2003 11:48 AM
Turn Signal Problem Studrat R170 SLK-Class 4 06-24-2003 07:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome