New 92 300E owner in OKC - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-26-2009, 11:44 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2009
Vehicle: 92 300E 256K miles
Location: Oklahoma City
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New 92 300E owner in OKC

Hey everyone,

I got my 300E on July the 5th and have been doing some things here and there, It had all the service records from day one with the car and I got it from the 1st owner and they have two other well they had one plus mine just bought a brand new one to replace mine with.

They had replaced the transmission 3.5 months ago or rebuild spend 2500.00 on it. I also have a receipt where they had the motor rebuilt 2.5 years ago on the car as well "guessing the head gasket gave maybe from what I have heard its common with the 200k mile cars"

I have a few issues with the car now, but for the 500.00 they sold it to me for it's all good and I'm willing to throw some money into it.

The reason they said they wanted to sell it was that the ac quit and they just wanted a new model so they went out and bought it and was hopeing that someone would get the car that would fix the few small issues with it.

Took the sunroof apart since it wouldn't work 100% and cleaned out the roof where it looked as if a rat had tried to build a home inside there somehow and now the roofs working fine.

The radio antenna don't work and stays down, which is fine I use my cd or Ipod anyway

The ac of course, its also been changed to 134, the compressor works and its full of freon, the guy at the ac place checked it and claims there is a relay under my center console that's bad that's going to cost me 300.00 for the relay to fix, but yet I cant find any mention of this relay being there anyplace.

My oil pressure sending unit is acting up, from what I have read at a few places I'm going to guess its the sensor because it works half the time and don't the other and its been driven a good bit with it reading "0" and I'm still going.

I think I have a vacuum leak or vacuum issue somewhere I read on a few sites it will make the transmission shift crazy at times, sometimes when I take off from a stop sign or light and the car gets up to around 3k with it floored it will kick down I guess to first and then shift out into second.... it does it randomly and the fluids good and clean..... I have read that the take off because its second gear is what makes them so slow from a stop light and I have seen people claim of there tires spinning "my car couldn't spin a tire unless I was an idiot and neutral dropped it" so I'm guessing I might have an issue maybe?

oh and my rear drivers side window don't work, can hear the cables flopping in the door but that's simple and pretty minor and can figure that part out.

So far I done the basic plugs, air filter, I'm going to do the fuel filter and the plug wires, where is the best place to get parts for our cars also?

I love the car so much and it drivers so smooth and nice on the highway, just have to figure my random cruise out with it, but it's a great car so far and cant wait to get the small stuff fixed and solved.

Sorry I made it so long everyone!

Donnie
Thisguy31 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-27-2009, 12:40 AM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Newbie in OKC mpsmith General Mercedes-Benz 3 07-26-2009 11:04 PM
    New member from OKC huyanh General Mercedes-Benz 1 03-24-2009 12:15 AM
    1988 MERCEDES BENZ 560 SEC/AMG - $16000 (OKC) RJMBurgess W126 S,SE,SEC,SEL,SD,SDL Class 31 03-21-2009 11:42 AM
    New '90 300E owner Andy_M W124 E,CE,D,TD Class 10 07-27-2007 06:02 AM
    Recomendations for detailers in OKC area snowbilt General Mercedes-Benz 2 05-04-2006 05:50 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome