New User with ML320 error codes (pls help!) - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-21-2009, 02:23 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2009
Vehicle: 2000 ML320
Location: Texas
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to dlakstins
(Thread Starter)
New User with ML320 error codes (pls help!)

Hi everyone, I've enjoyed reading this forum for a while and have benefitted from a lot of advice given to others (i.e "machine gun locks" issue) Now I seem to have an issue that I can't find the answer for so I figured it was time for me to register and start giving back a little. Here's what is going on:

2000 ML320 106k miles went into "safe mode" Reset and now it drives great but I have lots of dash lights and beeping. Here are the error codes I'm getting:

P0136
P0720
P0500
P0141

Once again the truck drives perfect. I did have the front brakes done the day before it went into safe mode but thats probably a coincidence.

I was out of town when the problem occured and took it to a dealer I'd never been to before. They told me the washer fluid leaked onto the ESP pump and it was burned out, wanted $2,800 + tax to replace. The story seemed weird because it didn't seem to match the error codes and I'd never seen a leak until they pulled it out of their shop so I refused service and drove it 4 hours back home. I'm ready to take it to my local dealer here but would like to see what opinions are out there. Thanks in advance for your help and I promise to contribute back to the board as much as I can!
dlakstins is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-21-2009, 07:13 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,282
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
P0136 O2 Sensor Circuit Malfunction (Bank 1 Sensor 2)
P0141 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)

P0500 Vehicle Speed Sensor Malfunction
P0720 Output Speed Sensor Circuit Malfunction

From the first 2 codes, it looks like you have an O2 sensor that needs to be replaced. Easy to do. Just unplug the connection and unscrew the post cat sensor on that side. Autohaus az usually has the best prices on w163 sensors. (Just make sure the ML is cold when you do the sensor change.)

Not sure about the last 2 codes. You can do a search or post this on the w163 forum if you do not get an answer here.

Good luck and welcome to the board.

Mike
Michael Pillay is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    error codes bjspringer W210 E-Class 2 05-11-2009 08:43 PM
    got a few error codes and need some help mandrioaie W202 C-Class 4 04-28-2008 04:05 PM
    Error Codes? graystarr W201 190-Class 2 11-01-2007 12:57 PM
    1999 ML320 Error Codes PO161 & PO156 FixMyBenz W163 M-Class 1 12-03-2005 08:01 PM
    Resetting FSS - an error in user manual JustAGuy R170 SLK-Class 7 04-10-2004 09:59 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome