W163 AC Compressor clutch not engaging - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-10-2009, 02:34 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
W163 AC Compressor clutch not engaging

Original owner 160K first problems with AC, blowing hot so recharged with 134a and seems to hold pressure very nicely, no apparrent leaks filled to about 60psi. Fuses and relays in main fuse box are all ok. Compressor clutch spins freely but still will not engage after recharge. Also cannot get aux. cooling fans to run. If problem is switch or sensor please help me find them under the hood.

ML430 Dude is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-10-2009, 10:57 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is online now  
post #3 of 3 (permalink) Old 07-13-2009, 08:02 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
compressor engagement

Thanks for the reply. I have searched and searched the w163 forums but have not found much at all about compressor problems specifically. BTW I did get the aux fans to run by puling out the connector for the engine temp sensor. Nothing I have tried so far will get the compressor clutch to engage however, even though it turns free and system is charged well.
ML430 Dude is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    No A/C: Compressor not engaging chinny4290 W124 E,CE,D,TD Class 11 05-28-2009 05:31 PM
    Compressor Clutch not engaging Air Conditioning gauthier613 W202 C-Class 1 06-12-2008 08:10 PM
    AC Compressor not engaging CBFintheODD W210 E-Class 8 03-24-2008 08:27 AM
    AC Compressor not engaging kburks1230 R/C107 SL/SLC Class 8 07-06-2007 02:01 PM
    A/C Compressor Not engaging.... AFARR W201 190-Class 1 07-14-2005 09:42 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome