What has been going on with my 1990 2.6L 190E - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-08-2009, 12:33 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2009
Vehicle: 1990 2.6L 190E
Location: Oklahoma
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post What has been going on with my 1990 2.6L 190E

I am posting a thread hoping for a reply as to what is/has been going on with my '90 MB.

I was driving down the interstate one day and noticed a whirring sound as if my car's RPM's were higher than normal. I immediately stopped and checked all fluid levels, only to find out that they were normal. I got back on the interstate, and when I accelerated past say 60mph, the noise faded away. At first it went away for a noticeable amount of time, then it began to come back every time I started my car and got on the highway. As time passed, the noise would remain longer and I would have to accelerate to greater speeds to get it to go away. Up until about a month ago the noise would stay until around 70mph. Now, the noise is seemingly constant. It might fade away at around 75mph, but if I drop below that speed it will remain.

Current status of car:
The check engine light is on, and I am fairly sure that the oxygen sensor needs replaced, and maybe even the EGR valve... When I stop at a stop sign, my car begins to vibrate, but if I switch to neutral, if usually goes away or minimizes so much that the door panels quit making so much noise. If the A/C is on, it seems to vibrate even more, and there is really no noticeable difference in RPM when in drive, or in neutral, or when the A/C is on or off. My transmission has been replaced... and it still leaks, and shifts hard into first gear (other gears are fine). There is no noticeable jerking or thump as car downshifts. The car doesn't smoke or have any other engine problems other than an oil leak (presumably around the head gasket - but unsure of exact location). Also, the car has over 200,000 miles (odom. broken at 176,000+) When I drive at slow speeds the car seems to make an intermittent noise, almost as if there is a sticker attached to one of the front wheels - this noise is very hard to notice.

Main Questions:
Is this possibly a problem with the Idle Air Control Valve?
Something else?
Has anyone ever had the same problems?
Could the intermittent noise and whirring sound be the same problem (such as a shot/damaged wheel bearing)?
How can I troubleshoot these symptoms?
tapp1777@yahoo.com is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-10-2009, 02:31 PM
awg
BenzWorld Junior Member
 
Date registered: Apr 2006
Vehicle: 2001 S500,1973 Detamaso Patrera
Location: Las Vegas
Posts: 45
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Send a message via MSN to awg
Check and see if your transmission mount is broken/flat and also your engine mounts.It almost sounds like your trans mount is/was starting to crack/go flat and that can cause a vibration/low decible noise going thru your car.
awg is offline  
post #3 of 3 (permalink) Old 07-10-2009, 02:35 PM
awg
BenzWorld Junior Member
 
Date registered: Apr 2006
Vehicle: 2001 S500,1973 Detamaso Patrera
Location: Las Vegas
Posts: 45
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Send a message via MSN to awg
Also check your driveline/flex disc maybe it's coming apart and hitting the tunnel of the veh.Also when you say you turn on the a/c the vibration gets worse ,I can put some money on all the mounts are flat and hitting/laying on the chassi.
awg is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    FS: 1990 190e 2.6 Kynyption For Sale/Wanted/Trade/Giveaway 23 02-28-2009 07:25 PM
    Just got a 1990 190E 2.6 bsweatt407 General Mercedes-Benz 0 02-03-2009 10:20 PM
    just got a 1990 190e 2.6 ry_dawg W201 190-Class 7 03-10-2006 05:56 PM
    190E 2.3 1990 gabinz General Mercedes-Benz 1 08-30-2005 05:43 AM
    1990 190E 2.6 wae96 W201 190-Class 4 10-28-2003 10:52 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome