500 sec rough idle (cold) - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-02-2009, 10:13 AM Thread Starter
BenzWorld Junior Member
Date registered: Jul 2009
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
500 sec rough idle (cold)

Hi, I'm new to the forum. I just bought a 1985 500 SEC and it's been idling a bit rough with an occasional surge. Cleaned the ICV and fixed a vacuum leak, which helped alot. It still idles a little on the rough side, but now it has a new problem. On cold start only, it starts right up, then it starts surging.....woomp woomp woomp. gauges and tach all surge. does this for about a minute until it slightly warms, then goes away and idles ok. Does anyone have any suggestions? Someone said to check the MAS, but I don't think this car has one.

Also going to do an oil change. Live in the Northaest. What grade of oil should I use? 10-30, 10-40, 20-50?

jojo101 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 07-02-2009, 09:47 PM
BenzWorld Elite
GogglesPisano764's Avatar
Date registered: Feb 2008
Vehicle: 1983 300D Turbo Diesel
Location: Brewster,NY (Putnam County)
Posts: 1,799
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to GogglesPisano764
Welcome to Benzworld!! For faster response post your questions in the W126 section of the forums. That section is specific to your car. I'm sure one of the other 126 owners would be glad to help you!

Yes Honey! Thats how they sound! Its a diesel!
MBCA Member
1983 300D "Schultz" (Relocated to Canada)
1983 300D "Klaudia" (My new love)
1985 300D (Whipped then Stripped)
1985 300SD (In way over my head and let go)
2002 Suburban Z71 (Eats gas stations during trips)
2004 Aveo (Only because I enjoy stuffing my fat ass in a tiny car. Oh and it gets good gas mileage)
GogglesPisano764 is offline  
post #3 of 3 (permalink) Old 09-06-2009, 12:28 AM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Low idle, rough idle, stalling, hot and cold start solved: E320/300 rvenerac W124 E,CE,D,TD Class 10 03-22-2010 11:28 PM
    Cold rough idle zft325 R170 SLK-Class 6 11-05-2008 12:38 AM
    Rough idle when cold dnewman W210 E-Class 5 11-15-2006 09:48 AM
    500 SEC Rough Idle Minkoff W126 S,SE,SEC,SEL,SD,SDL Class 8 01-04-2006 01:58 PM
    500 sec rough idle zulumack W126 S,SE,SEC,SEL,SD,SDL Class 3 12-23-2004 05:59 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome