London Calling - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-28-2009, 04:53 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
London Calling



Hi there - just joined. Have a C180 salon, manual, petrol, 1993 model. All well till now. Hoping that you guys can help me out. I postthe issue here as well as in the vehicle section.

Just had car service ( new plugs, filters,oil...), ball joints changex2; 4 new tyres, MOT passed; however when starting the car in the morinings it would just turn and fire and ll Ok. Now it turns but does not fire, have to press the accelerator pedal for it to fire aand then it spluters and mis fires, finally warms up for me to move in first gear but with very little to no power. After about 3 mins the car warms up and all is OK - power back, no misfiring or splutering; however not as smoth as before but driveable.

Have checket the temp gauage sensro read 5K ohms cold and 20Ohms when hot.
Any ideas...manual states could be throttle body? any tips.

Hope you guys ( & gals) can help.

Ta
C180MB is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-28-2009, 06:12 PM
BenzWorld Elite
 
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld
livefreeordie is offline  
post #3 of 5 (permalink) Old 06-29-2009, 12:53 AM
BenzWorld Elite
 
GogglesPisano764's Avatar
 
Date registered: Feb 2008
Vehicle: 1983 300D Turbo Diesel
Location: Brewster,NY (Putnam County)
Posts: 1,799
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to GogglesPisano764
Welcome to Benzworld!

Yes Honey! Thats how they sound! Its a diesel!
MBCA Member
1983 300D "Schultz" (Relocated to Canada)
1983 300D "Klaudia" (My new love)
1985 300D (Whipped then Stripped)
1985 300SD (In way over my head and let go)
2002 Suburban Z71 (Eats gas stations during trips)
2004 Aveo (Only because I enjoy stuffing my fat ass in a tiny car. Oh and it gets good gas mileage)
GogglesPisano764 is offline  
post #4 of 5 (permalink) Old 09-06-2009, 12:36 AM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
post #5 of 5 (permalink) Old 09-06-2009, 01:15 AM
Lifetime Premium Member
 
Date registered: Dec 2004
Vehicle: 1972 280CE
Location: Dallas, TX
Posts: 3,888
Mentioned: 1 Post(s)
Quoted: 108 Post(s)
Lifetime Premium Member
Cold start injector?

With best regards

Al

Check out the W114, W115 /8 enthusiast forum http://www.stroke8.org

My 280SL restoration
alabbasi is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    New from London smugee General Mercedes-Benz 4 09-07-2009 03:35 AM
    OT : London anyone? Sandman1962 R170 SLK-Class 1 04-12-2008 11:06 AM
    OT: So Im in London MarkR170 R170 SLK-Class 6 07-17-2006 05:23 AM
    need help from london Mr Wolf R171 SLK-Class 4 04-03-2004 02:42 PM
    OT: Anyone here from London? Qui R170 SLK-Class 11 07-21-2003 08:05 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome