Loss of power in my 02 ML320 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-28-2009, 08:49 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Loss of power in my 02 ML320


I own a 02 ML320 since 04. I brought it used never had any mechanial problem until now. Car has 66000 miles now I have constant yellow engine light on it when I drive it looses power, shakes & rattle. I have taken it to a Mer mechanice shop they have changed the camshaft sensor but the problem remains. I have never changed the mass air flow sensor or oxygen sensors at all. Could it be fuel filter, fuel pump, MAF or oxygen sensor ? Or anything else please help, Thanks.
monwar99 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-28-2009, 11:46 PM
BenzWorld Elite
GogglesPisano764's Avatar
Date registered: Feb 2008
Vehicle: 1983 300D Turbo Diesel
Location: Brewster,NY (Putnam County)
Posts: 1,799
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to GogglesPisano764
Welcome to Benzworld!

Yes Honey! Thats how they sound! Its a diesel!
MBCA Member
1983 300D "Schultz" (Relocated to Canada)
1983 300D "Klaudia" (My new love)
1985 300D (Whipped then Stripped)
1985 300SD (In way over my head and let go)
2002 Suburban Z71 (Eats gas stations during trips)
2004 Aveo (Only because I enjoy stuffing my fat ass in a tiny car. Oh and it gets good gas mileage)
GogglesPisano764 is offline  
post #3 of 3 (permalink) Old 09-05-2009, 10:20 PM
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    power loss beckerschmidt W124 E,CE,D,TD Class 0 11-12-2008 06:42 PM
    loss of power stuart.wilson W202 C-Class 4 10-09-2008 07:50 AM
    loss of power!!! myslk230 R170 SLK-Class 2 12-19-2006 12:00 AM
    ML320 loss of power Gusman W163 M-Class 5 11-06-2004 10:02 PM
    Power loss? Samir C208/A208 CLK-Class 1 05-01-2001 09:41 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome