w211 fan not working - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-17-2009, 10:50 AM Thread Starter
BenzWorld Newbie
Date registered: May 2009
Vehicle: 2003 e270 advantguard
Location: n.ireland
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to tucker2904
(Thread Starter)
Exclamation w211 fan not working

please help just bought 03 e270 now its over heating averaging 100 - 110 fan only comes on when heater turned on and does come on when engine reaching these temps... had it on diag and came up with thermal over load and spike to ecu... this guy who done this diag nevercharged me as he was unable to do anything to fix this prob......has to go to dealer for diar and repair...crapping myself now as to wot maybe prob...as in ecu gone... any one who can help on this would be very very app....thks guys
tucker2904 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-18-2009, 10:00 AM
administrator's Avatar
Date registered: Mar 2006
Vehicle: Mercedes c350
Location: Toronto, Ontario
Posts: 2,225
Mentioned: 5 Post(s)
Quoted: 132 Post(s)
Lifetime Premium Member
Welcome to the forum! Can anybody help out here?


If you have any suggestions or feedback, please PM me.

administrator is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Auxilary fan not working Jevile219 W126 S,SE,SEC,SEL,SD,SDL Class 11 09-17-2008 12:51 AM
    electric fan not working wilkoo2 R170 SLK-Class 16 05-15-2007 07:19 AM
    Heater fan not working mbc220 W202 C-Class 2 11-26-2005 06:15 PM
    126 HVAC Fan not working / Heater Fan Removal cam69ss W126 S,SE,SEC,SEL,SD,SDL Class 1 01-25-2005 10:31 AM
    Fan not working Nikv R129 SL-Class 2 08-22-2003 07:44 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome