ABC problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-16-2009, 05:15 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ABC problem

I am new to this forum but reading through the posts, they are very helpful. I am hoping someone can help me pinpoint my problem. I have a 2003 SL500, Love the car but it began to dip a small amount in the right rear when parked and not running. When I checked my ABC fluid, it was at the right level, when I checked it while it was running and the rear was not drooped, it was down, I added fluid, drove it for about 5 miles, shut it down, it still drooped, however now because I had more fluid, the fluid began to seep out of the cap on the reservoir. I am assuming the valve block is staying open on that wheel allowing the fluid back to the reservoir? When it starts and drives, it immediately goes back up and stays up. Do I need a new valve block on the rear?
TomBurns is offline  
Sponsored Links
post #2 of 3 (permalink) Old 08-02-2009, 10:34 AM
leapyfish is online now  
post #3 of 3 (permalink) Old 08-02-2009, 11:01 PM
BenzWorld Member
garybc230's Avatar
Date registered: Jul 2009
Vehicle: 2006 SL500/2006 Porsche Cayenne S Titanium
Location: Upper Marlboro, MD
Posts: 55
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It looks like you posted your question quite awhile ago, did you ever get an answer to your question. Looks like not, anyhow, ABC is a pain in the ass. When I bought my 06 SL 4 months ago, the first fault to occur was the ABC. Took it to the dealer(it was under warranty) and they replaced some parts and the light went out.

Since an 03 is probably out of warranty unless you have an extended warranty, take it to an independent dealer and have them look at it. They can hook it up to STAR and see what fault codes you're getting. Have them take a look at it sooner than later, because the quicker you diagnoise the problem the less out of pocket expenses later.

Currently Drive:
06 SL500 Pewter w/Berry Red interior Sprint Booster
06 Porsche Cayenne S Titanium Red w/black & beige interior
garybc230 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Help Please!! Problem with ABC Car Freak C215 CL-Class 44 05-12-2012 12:06 AM
    Got the dreaded abc problem! Help! Eway C215 CL-Class 7 04-13-2009 06:16 PM
    ABC PROBLEM EUROPEANSPORT W220 S-Class 7 06-03-2008 12:03 AM
    SL500 ABC PROBLEM HELP ME PLEASE clk4302002 R230 SL-Class 3 06-21-2007 01:17 PM
    ABC problem. Please help!! John in Norcal C215 CL-Class 15 04-18-2007 03:46 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome