BAS/ASR/ABS Warnings - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-13-2009, 08:21 AM Thread Starter
JTC
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 39
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
BAS/ASR/ABS Warnings

Ok, that perennial favourite, the holy trinity of warning lights.

I have a 1998 320 CLK and since I got it I have been plagued by this intermittent problem. First the stop lamp switch was replaced but about 2 weeks later the problem recurred. Yesterday a new fault was diagnosed as being the nearside rear wheel speed sensor, so that was replaced. Problem still occured.

The wheel assembly and sensor assembly were stripped down and reassembled and the problem has not returned but I'm not hopeful it has been cured.

When this warning light comes on it does cure itself after driving for about 15 minutes and I turn the engine off and restart. The cruise control doesn't work when I get the warning and shortly before I get the warning I feel a gentle scrape under the brake pedal.

If it helps, I also get the occasional 'engine fan' warning but the error is not logged and the fan is working fine (the fan control module was replaced a month ago).

My mechanic thinks that if it isn't the wheel speed sensor, it could be the hub or whatever the speed sensor reads from. Voltages check out fine btw.

Any other possible causes of this problem?
JTC is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    BAS/ASR & ABS light simultaneously came on today. 1999 S320. W140FTW W140 S-Class 23 01-07-2015 08:22 AM
    ABS...BAS/ESP WARNINGS!!! Failure 1stbenz2kE55 W210 E50 AMG, E55 AMG 14 02-08-2011 03:41 PM
    ABS & BAS ASR lights on ccrobins The Discount Tire Direct Tire, Wheel, Brake & Suspension 0 06-30-2006 02:28 AM
    ASR, BAS, ABS ligts - different problem NordRhein W202 C-Class 1 08-21-2005 09:37 AM
    Benzdoc...opinion needed on (ABS\BAS-ASR) Classic_wong118 W140 S-Class 2 07-11-2005 05:32 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome