Greeny with a 1999 C230K - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-11-2009, 09:46 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2009
Vehicle: 1999 C230 Kompressor
Location: ID
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Greeny with a 1999 C230K

Hey Guys,
I have no idea if i am doing this right. I love my C230. Unfortunately I recently started getting a P0170 code. I looked into and found that i have oil in my MAF. Is there anything i can do about this? Thanks in advance for any help.
argentinebenz is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-12-2009, 12:35 AM
BenzWorld Elite
 
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld, do a search on MAF, there are many threads on how to clean them.
livefreeordie is offline  
post #3 of 3 (permalink) Old 06-12-2009, 10:06 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2009
Vehicle: 1999 C230 Kompressor
Location: ID
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by livefreeordie View Post
Welcome to Benzworld, do a search on MAF, there are many threads on how to clean them.
Thanks, i will check that out. i just didn't know if there was leak i should resolve at the source or just continue to clean the MAF.
argentinebenz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1999 c230K won't crank jceh1 W202 C36 AMG, C43 AMG 1 01-25-2009 10:18 PM
    1999 vs. 2000 c230k nokkieny W202 C-Class 3 12-21-2007 07:05 PM
    1999 C230K NOOB questions barrysuperhawksh W202 C-Class 2 11-09-2007 01:37 AM
    1999 C230k transmission problems connman W202 C-Class 10 09-27-2007 09:21 AM
    1999 c230K --- what do I need to know?? starketcher W202 C-Class 2 08-30-2007 07:14 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome