High idle problem 1989 560sel 160,155 miles - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-11-2009, 05:55 PM Thread Starter
BenzWorld Junior Member
Date registered: May 2009
Vehicle: 1999 CLK 430
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile High idle problem 1989 560sel 160,155 miles

Please anyone with procedure on how to remove ICU casing to test connections also repairing ICV unit instructions with step by step directions saving time and most important MONEY!!! Thanks in advance ALSO any one who can send pics for reparing window regulator slip jaw clip never done before instructions included please again step by step. Trying to save money on repairs. caring for my mom who had a stroke and she needs my financial help. THANKS SO MUCH!!!
jdsilver560sel is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Testing Idle Valve - High Idle Problem Jonathan Laws W126 S,SE,SEC,SEL,SD,SDL Class 16 08-11-2012 05:55 AM
    1989 560SEL, 85K miles, $2000... to loss W126 S,SE,SEC,SEL,SD,SDL Class 4 09-11-2007 06:10 AM
    Help w/my 1989 560sel electric problem scottie99 W126 S,SE,SEC,SEL,SD,SDL Class 2 07-29-2007 11:51 PM
    FS: 1989 560SEL AMG Personal Limo w/35K miles, $29K OBO brucemendel For Sale/Wanted/Trade/Giveaway 3 11-27-2005 10:03 PM
    88 560sel high idle, rough hot start elroythekid W126 S,SE,SEC,SEL,SD,SDL Class 22 05-19-2005 05:30 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome