ml500 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-06-2009, 03:58 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ml500

forced to try to do my own repairs ... ,2002 ml 500 battery is dead. When I tried to jump start it, it wouldn't turn over. Everything electrical came on, however. Is this just a really, really dead battery? How do I change it? could it be something else? thanks
bamaray1941 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-06-2009, 04:13 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,915
Mentioned: 2 Post(s)
Quoted: 591 Post(s)
Juice and no crank suggests a different issue.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #3 of 3 (permalink) Old 06-06-2009, 06:47 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,282
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
Check the voltage on the battery with a voltmeter. If you search the w163 forum, there was a thread not too long ago about batteries. You should find all the info you need in that thread.

Mike
Michael Pillay is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    I now own a 03 ML500! j3cubcapt W163 M-Class 18 11-04-2008 02:47 AM
    Considering a ML500... dragoncoach W164 M-Class 6 08-01-2007 06:29 PM
    ***WIN a 2003 ML500*** They are giving away a ML500 at .............. garyroseyu W163 M-Class 3 12-02-2002 02:50 PM
    ML500 is in!! Charley W163 M-Class 3 11-21-2001 07:04 AM
    ML500 0-60 02ML500 W163 M-Class 9 11-14-2001 06:11 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome