Software glitches in Comand system - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-31-2009, 09:56 PM Thread Starter
BenzWorld Member
 
Iridium's Avatar
 
Date registered: May 2009
Vehicle: 1984 300D Turbo
Posts: 243
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
Software glitches in Comand system

Hi all

New member here, so I hope this hasn't been covered already. The 2009 GL320 Bluetec is my first MB and I'm still getting used to the "Mercedes way" of doing things. (Battery under the front seat, etc.)

So far everything is good except for some odd glitches in the COMAND system. Frequently the digital clock freezes, while the analog continues keeping perfect time. Pressing any button on the COMAND unit gets the clock going again, but I'm wondering if there's a software update or other fix to resolve this.

On the dash, the temperature gauge sometimes locks up too, at unrealistic temperatures. Today it was working fine until I had the car washed, then it stuck at 69 degrees for the rest of the day. Actual temperature was over 95 degrees. Even after two starts and several hours in the sun, the temp gauge stayed at 69. This happened on delivery day too, stuck at 70 degrees on a 100-degree day, but resolved itself after a few hours.

Yesterday, I started the car and the COMAND unit automatically linked to my Bluetooth phone as it is supposed to do. But then it started ringing with the message, "INCOMING CALL FROM UNKNOWN". But there was no call -- my phone was not ringing. The car wouldn't stop ringing even if I tried to answer the "call". If I pressed disconnect, I'd get another "call" a few seconds later. I finally resolved this one by shutting off my phone, so it may have been a phone-related glitch instead.

I love driving the car and expect to have it for many years, but I have to say I'm unimpressed with the complexity of the COMAND user interface, and software glitches are just inexcusable. Any suggestions for resolving these, or should I just go to the dealer and hope they have a software update?

Thanks
Iridium is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-31-2009, 11:19 PM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Considering your phone problem, I would check if there was a SW update for it and if possible, I would try another phone. It really looks like a phone issue. But isn't BT HF integrated to Comand in your car, if the Comand unit is misbehaving, never know if this phone issue is another symptom.

The digital clock freezing (on the Comand?) sounds like a SW issue with the unit. But I tried to find out some previous knowledge about a similar issue and found nothing. Sounds like it was no known fault. You might get better replies from owners at the GL forum, hopefully here too. A SW update, if available, would be a good thing to start from.

A bit similar with the temperature gauge, I would try to take a photo of it malfunctioning and show it at the dealer. After all, everything in your car should work and should be fixed under warranty. Intermittent issues are just a bit difficult sometimes.
Diesel Benz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Shall I replace my COMAND? or just the Software? giorgoc Audio & Telematics Forum 32 11-09-2012 02:06 AM
    COMAND Software DansSlk Audio & Telematics Forum 10 07-09-2006 08:31 PM
    Comand software update firemist350 R171 SLK-Class 12 03-22-2005 07:23 AM
    Software crash on COMAND system kmm&m W211 E-Class 5 06-30-2004 11:28 AM
    ML Software glitches. tcp_ML500 W163 M-Class 15 05-13-2003 10:15 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome