Transmission problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-31-2009, 03:56 PM Thread Starter
BenzWorld Junior Member
Date registered: May 2009
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Transmission problem

My 1989 300SEL just stopped shifting into high gear. It was running at 3200 RPM at 65MPH. Any suggestions as to what the problem and cost to repair could be and what kind of damage could be done if I continue to drive it.

Tosser123 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 05-31-2009, 05:35 PM
BenzWorld Extremist
Date registered: Feb 2008
Vehicle: 1987 420SEL
Location: Ontario, Canada
Posts: 1,133
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Rebuilding one of these can run up to $2500, which tends to be the solution as with a replacement, you really never know the exactly condition of the internals.

Try searching around the W126 forum on this site. There are some very helpful threads in there, just search '300SEL transmission issues' or something along those lines.

Before you get too serious about a replacement, do the normal service to the trans (ATF change, filter, pan gasket) and see what happens.

(On Edit)

They're finnicky to fill with fluid though; if you drain the torque converter, use the amount listed in the owner's manual. There should be values including the TC, and w/o. Fill the transmission about 3/4 full, keep track of the quantity that's in there, and drive the car. Check, add as necessary, repeat. This will continue for a couple days until the reading is consistant. Shift through all the gears before checking.

Last edited by Benz Prodigy; 05-31-2009 at 05:39 PM.
Benz Prodigy is offline  
post #3 of 3 (permalink) Old 05-31-2009, 07:56 PM Thread Starter
BenzWorld Junior Member
Date registered: May 2009
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Trans Problem

Thanks for the input.
Tosser123 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Help with transmission problem CLK forever C208/A208 CLK-Class 14 08-25-2007 12:44 AM
    Transmission Problem J-Ro R129 SL-Class 0 06-12-2006 07:05 PM
    Transmission problem? Avezbakiyev W210 E-Class 22 09-14-2005 01:17 PM
    Transmission Problem shark22 R171 SLK-Class 25 08-11-2005 02:22 PM
    Brake padal vibration problem + transmission problem Majid Mansoori W210 E-Class 11 09-22-2003 07:33 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome