Rear Defroster Malfunction - Please HELP!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-30-2009, 10:10 AM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2006
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Rear Defroster Malfunction - Please HELP!!

Hello,

I have a 2003 S430. Every time I turn on my rear window defroster, I pop the 50amp fuse under the rear seat. Any idea why this would be happening? It seems like this started once I had my rear window tinted. Does anyone know where the connections are for the rear window defroster or the relay? Any help would be appreciated. Thanks much!

Dave
istalion20 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-31-2009, 10:33 AM
BenzWorld Elite
 
Date registered: Dec 2002
Vehicle: 92 500SEL to 01 E320T and others
Location: Florida
Posts: 3,886
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
I think you are close to your question, the wires are behind the trim panel, they probably sliced them trimming the tint
Peter Guenther is offline  
post #3 of 4 (permalink) Old 05-31-2009, 05:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2006
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the response! What's a trim panel? lol I thought the rear defroster was built into the rear window? Is that not the case? I'm not that mechanically inclined so please try to be as specific as possible. Thanks so much.
istalion20 is offline  
post #4 of 4 (permalink) Old 06-02-2009, 09:56 PM
BenzWorld Veteran
 
Date registered: Apr 2009
Vehicle: Current: 1987 560 SEC US, former factory trained MB tech 10 years, owner of 14 others.
Location: Spokane, WA.
Posts: 723
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Yep, a dead short. You will need to take off the trim panel, and take a look were they essentially sliced off the insulation and that is your short. The rear package tray behind the seats is the trim piece.
renaissance_warrior is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Rear Defroster help on 1998 SL500 UK500 R129 SL-Class 10 12-23-2009 06:14 PM
    Rear Window Defroster Malfunction istalion20 W220 S-Class 4 11-14-2009 06:38 AM
    Rear defroster malfunction? Mr.Maxx W201 190-Class 14 11-26-2007 07:14 PM
    rear defroster jesster W203 C-Class 4 02-02-2007 03:06 PM
    Rear Defroster Malfunction Nutz 4 Benz W201 190-Class 2 01-23-2006 02:34 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome