C220 Automatic CDI Not starting - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-27-2009, 10:14 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2008
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Red face C220 Automatic CDI Not starting

It takes several attempts to start my 2000 C220 CDI. When I turn the key the starting 'process' just does not begin at all. I turn the key off, wait for the immobaliser to engage, and try again. It can take up to 10 attempts before the car starts. It almost appears as if the gear leaver is not in the 'P' position. ANy ideas ??

Thanks & Cheers
simonbe is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-27-2009, 11:34 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by simonbe View Post
It takes several attempts to start my 2000 C220 CDI. When I turn the key the starting 'process' just does not begin at all. I turn the key off, wait for the immobaliser to engage, and try again. It can take up to 10 attempts before the car starts. It almost appears as if the gear leaver is not in the 'P' position. ANy ideas ??

Thanks & Cheers
If the key turns in the ignition slot, then it is not the gear position switch.

How does it work with your second key?
Diesel Benz is online now  
post #3 of 7 (permalink) Old 05-27-2009, 11:43 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2008
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I dont have a second key, unfortunatly
simonbe is offline  
post #4 of 7 (permalink) Old 05-27-2009, 12:31 PM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by simonbe View Post
I dont have a second key, unfortunatly
I should not ask people to try their second key, for some odd reason that always makes their second key disappear. Now you cannot be sure if it is the power coil in the key loosing contact from its soldering. Unless you open the key. But it could well be the EIS too, not extremely rare.
Diesel Benz is online now  
post #5 of 7 (permalink) Old 08-31-2009, 02:43 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2008
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Still No Joy

Quote:
Originally Posted by Diesel Benz View Post
I should not ask people to try their second key, for some odd reason that always makes their second key disappear. Now you cannot be sure if it is the power coil in the key loosing contact from its soldering. Unless you open the key. But it could well be the EIS too, not extremely rare.
OK I bougt a new key but it still does not work, in fact it now will not start at all (with old or new key). When I turn the key there is just a 'clunk' sound at the top left side of the engine, almost as if something is 'stuck'.

Any Help........please
simonbe is offline  
post #6 of 7 (permalink) Old 08-31-2009, 03:32 PM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by simonbe View Post
OK I bougt a new key but it still does not work, in fact it now will not start at all (with old or new key). When I turn the key there is just a 'clunk' sound at the top left side of the engine, almost as if something is 'stuck'.

Any Help........please
Sounds like a very traditional starter motor/solenoid issue, nothing about the complex electronics of modern MBs. You can diagnose it by measuring the voltage from the solenoid input. If you can measure a proper drive signal, the starter motor or solenoid have issues.
Diesel Benz is online now  
post #7 of 7 (permalink) Old 08-31-2009, 03:47 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2008
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Sounds like the First bit of real progress

Quote:
Originally Posted by Diesel Benz View Post
Sounds like a very traditional starter motor/solenoid issue, nothing about the complex electronics of modern MBs. You can diagnose it by measuring the voltage from the solenoid input. If you can measure a proper drive signal, the starter motor or solenoid have issues.
Hey, thanks for that. As a mater of fact I had to 'override' the solenoid about 6 months ago as the gear stick was stuck in 'P'. Now I need to get someone to measure the voltage.
simonbe is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    C200 cdi v c220 cdi are they same engine? h9llw W203 C-Class 2 01-03-2011 02:35 PM
    C220 CDI kevin b Benzworld Site issues forum 0 01-23-2009 05:29 AM
    C220 CDI Coupé Automatic gearbox problems! - PLEASE HELP! warrenrs W203 C-Class 0 04-14-2008 01:49 AM
    C220 CDI Manual vs automatic Bhans W203 C-Class 6 11-09-2002 08:22 PM
    Driving a C220 CDI Automatic this week on the Autobahn... Chuck V W203 C-Class 0 08-23-2002 03:38 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome