heat and air problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-18-2009, 08:47 AM Thread Starter
BenzWorld Newbie
Date registered: May 2009
Vehicle: 2002 M-class ML 320
Location: Wilmington NC
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
heat and air problem

I bought my second hand 2002 M-class about 2 months ago. Soon after I noticed a chemical smell when the air was on, so I shut it off. Since it was cool out, I drove without AC for awhile. Then when I tried to turn it back on it it didn't work. The compressor does not come on and the windshield and center vents don't blow any air. The side and floors vents work fine. Today I tried to run the heat and it doesn't work either.

I took it back to the dealership where I bought it (Honda/Acura) and they were3 clueless. Before I take it to the MB dealer for repair I wanted to get an idea of what I might be looking at; i.e does this sound like it only needs refrigerant or is a vehicle of this age likely to need a major repair? And in both cases what kind of costs should I expect?

Any tips would be helpful.
Joy Allen is offline  
Sponsored Links
post #2 of 4 (permalink) Old 05-18-2009, 10:19 AM
BenzWorld Elite
Check Codes's Avatar
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Hi, Joy, welcome to the forum.

Please click the User CP link and complete your BW profile for vehicle and location as that is often useful information, then it's in every post. And re: location often another member will be able to recommend a decent shop near you.

There is a forum that is specific to your SUV and it is the W-163 forum. If you scroll down the main page you will find it and if you post in there you're more likely to get answers that are specific to your vehicle. The general forum is more for things of interest to all MBs.

The chemical smell may just be dirty cabin filters, yours may also have the charcoal ones. Replacing those will usually clear that up.

On many models the air direction is controlled by vacuum, so it could be something that simple. When you say it "doesn't work" you only mean the air direction, right? You get cold air on AC and hot air, but only from the side and floor vents? Those are entirely different problems, so it's important to be precise on an internet forum.

At any rate, post with a bit more detail into the 163 section and they'll point you in the right direction.

Take care and enjoy the ride,

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 4 (permalink) Old 05-18-2009, 11:34 AM
BenzWorld Elite
Michael Pillay's Avatar
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,271
Mentioned: 0 Post(s)
Quoted: 78 Post(s)
Michael Pillay is offline  
post #4 of 4 (permalink) Old 05-18-2009, 03:29 PM Thread Starter
BenzWorld Newbie
Date registered: May 2009
Vehicle: 2002 M-class ML 320
Location: Wilmington NC
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Thanks for welcoming me to the forum and for the tips on using it. I will post my inquiry where you suggested and I will be more clear in describing the problem.


Joy Allen is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Oh boy, Air flow problem (A/C,heat) ghost W140 S-Class 11 10-02-2009 03:05 PM
    Air Condition/Heat Problem shadwick W220 S-Class 6 03-03-2008 08:34 AM
    No heat or air R22Flyer R170 SLK-Class 5 02-02-2008 07:01 PM
    Air and heat DW140 W140 S-Class 2 08-28-2006 01:38 AM
    no more heat, a/c, or air lyrics10 W126 S,SE,SEC,SEL,SD,SDL Class 7 04-15-2005 08:33 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome