Wiper problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-12-2009, 07:24 PM Thread Starter
BenzWorld Newbie
Date registered: May 2009
Vehicle: 1998 C-230
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Wiper problem

The wiper on my 1998 C-230 just quite working. The motor will run when activated and the wiper assembly is easy to move by hand. Suggestions? How hard to repair?
stamp73 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 05-14-2009, 04:30 PM
BenzWorld Elite
Check Codes's Avatar
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Welcome to the forum.

Please click the user cp link and complete your profile for vehicle and location as that is often useful information.

If you jump down to the 202 forum and do a search you'll find this is a fairly common problem for that chassis, I'm not sure how far it gets into the detail for the repair. IIRC there is a little plastic clip that breaks or cracks and falls off.

Take care and enjoy the ride,

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 3 (permalink) Old 05-15-2009, 07:49 AM
BenzWorld Newbie
Date registered: May 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
This is my first reply into this forum so apologies up front if I break some protocol.

If you can move the wiper arm freely with the motor running, its almost certain the motor's teflon gear is stripped for at least part of the rotation of the wiper.

To get access to the motor, you have to remove the mesh trim under at the base of the window. These snap out. Then you'll see a large piece of trim which routs the water away from the engine. 10-12 screws and some hard pastic tabs hold this in place.

Once this is off, you'll see how to remove the entire assembly. You need to open the fuse compartment and unplug the motor wire, and then there are 3 bolts (may be hard to see) holding the entire wiper assembly to the chassis. Remove these bolts and unsnap the white plastive centering clamp, and the entire unit pulls out.

Flip it over and you'll see that the motor easily unbolts from the assembly. Make sure you note the position of the transmission and blade. Take a picture. You have to get the timing right to make sure the wiper articulates to the corners when you want it to. Get it wrong, and something will snap - the motor is pretty powerful.

Once the old motor is off, get an allen wrench and remove the control face plate. Look for gooey teflon shavings in the corners. Look at the teflon gear wheel. If the transmission and gear assembly was bound up, the worm screw would over time just chew away at the gear. Hence you will hear the motor run, but the blade does not move.

A new motor is about $240 online. But a word of warning, you can replace the motor and not fix the root cause the gear assembly. Thats what I did and I had the same problem repeat. The wiper blade transmission linkages were bent and i did not notice. New gear assembly is $440 online - for total project cost of $680 in parts. Ouch. Which is why the dealer was going to charge $900 to fix.

I ended up at a parts recycler - junk yard - and got the entire assembly -motor, linkages, wiper gear, blade. for $350. Seemed high for a junk yard - but I got 1 year guarantee which is as good as I'd get from MB. I installed and its working fine for 2 months now.
JWellen is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    wiper problem? inshane82 W202 C-Class 14 05-12-2009 01:08 PM
    wiper problem cal69 W203 C-Class 0 01-17-2009 11:30 AM
    wiper problem gouda2000 W140 S-Class 5 10-20-2006 08:42 PM
    Wiper problem endoskeleton1 R129 SL-Class 7 12-03-2005 09:18 AM
    Wiper Problem goinboardn W201 190-Class 1 10-03-2002 12:50 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome