300SD-1983 enjoying the ride - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-04-2009, 06:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2009
Vehicle: 1983 300SD
Location: NJ
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Wink 300SD-1983 enjoying the ride

I had this for 4 years and enjoying the ride. The ride became
uncomfortable when i started I get hot air instead of cold are in the front panel.
The rear passenger duct seems to function ok. Can anyone help out where i should start looking to?
rathri is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-05-2009, 03:59 AM
BenzWorld Elite
 
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld
livefreeordie is offline  
post #3 of 5 (permalink) Old 05-06-2009, 09:25 AM
Always Remembered RIP
 
cascade's Avatar
 
Date registered: Nov 2006
Vehicle: 1991 560SEC AMG
Location: Grass Valley, N. Calif. / Gardnerville, Nevada
Posts: 10,146
Mentioned: 1 Post(s)
Quoted: 17 Post(s)
Send a message via AIM to cascade
Welcome aboard!!!


Go directly to the W126 section and post your question there, and we will answer.


This could be one of several things, maybe an easy fix like a recharge or maybe not.

These cars do have a sometimes finicky history with the HVAC but they can be taken care of.

Jim
<--- superschnelle 300 hp 10:1 ECE euro HV, Hochverdichtung = high compression (11/2011) ... Wie im Freien Fall. Nur horizontal.


"I swear to god, it's like I live in a trailer of common sense, and stare out the window at a tornado of stupidity." >'='<
cascade is offline  
 
post #4 of 5 (permalink) Old 08-10-2009, 11:05 AM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 210,xxx Miles
Posts: 7,685
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
leapyfish is offline  
post #5 of 5 (permalink) Old 08-12-2009, 05:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2009
Vehicle: 1983 300SD
Location: NJ
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for this forum. I further noticed that I get cold air only if i start the engine,
Press the A/C button on after a cold engine start. It is fine when i drive in the AM
and fine i drive back to home in the PM. However, during the ride, if i turn it off
and turn it on again, then i start to get hot air. Any ideas? Thermostat dial all the time
in cold mode.
rathri is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1983 300sd beginners luck W126 S,SE,SEC,SEL,SD,SDL Class 6 03-09-2009 09:32 AM
New To Me 1983 300SD Earlybird W126 S,SE,SEC,SEL,SD,SDL Class 3 06-27-2005 05:49 PM
Question RE Interchangeable parts 1979 300SD - 1983 300SD Reedfarm W126 S,SE,SEC,SEL,SD,SDL Class 2 10-03-2004 08:03 PM
Looking at a 1983 300sd... patagrande W126 S,SE,SEC,SEL,SD,SDL Class 5 05-16-2004 05:57 AM
What music do SLK32 owners listen to while enjoying a ride? Shane R170 SLK-Class 22 09-15-2003 08:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome