Brake light fault - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 04-29-2009, 02:28 PM Thread Starter
BenzWorld Junior Member
 
smudgenav's Avatar
 
Date registered: Apr 2009
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Brake light fault

Hi all this is a fault that i hope someone has had some dealing with as i cant really afford to go to the dealers the fault is displayed on the dash when the brake pedal is pressed.

I bought a code reader and this is what the codes said
4404 The CAN signal from component S9/1 (Stop lamp switch) of the traction system is implausible
4600 The voltage supply of circuit 87 has undervoltage
4602 the voltage supply of the valves is faulty.

I changed the brake switch it had no effect!!

Pls Help
Andy

Last edited by smudgenav; 04-29-2009 at 04:36 PM.
smudgenav is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 04-29-2009, 04:29 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
I don't understand your last sentence. Did you mean you changed the brake light switch and that didn't solve the problem?

To state the obvious, did you check to see if both brake lights work? If not, check the bulb(s) and the socket(s) they plug into.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 12 (permalink) Old 04-29-2009, 04:34 PM Thread Starter
BenzWorld Junior Member
 
smudgenav's Avatar
 
Date registered: Apr 2009
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes mate i changed the switch and checked all the bulbs there is no power getting to the right hand brake light.
smudgenav is offline  
post #4 of 12 (permalink) Old 04-29-2009, 04:45 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Mate?...you sound like an Aussie! Now we're getting somewhere, no power. How about a bad fuse and do the wires look O.K? BTW it would be helpful for someone if you tell us what type of MB you have (year and model).

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #5 of 12 (permalink) Old 04-29-2009, 04:53 PM Thread Starter
BenzWorld Junior Member
 
smudgenav's Avatar
 
Date registered: Apr 2009
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Well as far as i can tell the wires look fine and all the fuses are too i have a C32 AMG (2002) all the other lights in that cluster work so im guessing its something upstream ?? and no im not an Aussie
smudgenav is offline  
post #6 of 12 (permalink) Old 04-29-2009, 05:02 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
In my car series (W210) the brake light sockets are often to blame for a brake lamp failure indicator so that's why I suggested that. If those are O.K. as well as the bulbs, wires and fuses, then it's indeed time to look upstream. That's where I'd be lost though; hopefully someone else will chime in. If all else fails, look for the model-specific forum for your car and ask the other C32 owners.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #7 of 12 (permalink) Old 04-29-2009, 05:07 PM Thread Starter
BenzWorld Junior Member
 
smudgenav's Avatar
 
Date registered: Apr 2009
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool il post this subject on the C32 owners forum and see if that can rattle a few answers.

Thanks for the chat bud.
smudgenav is offline  
post #8 of 12 (permalink) Old 04-29-2009, 05:14 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
My pleasure, and best of luck!

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #9 of 12 (permalink) Old 04-29-2009, 05:34 PM
BenzWorld Member
 
daddi's Avatar
 
Date registered: Apr 2009
Vehicle: E420 '94 240D '82 200E '91
Location: Iceland
Posts: 72
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by smudgenav View Post
Hi all this is a fault that i hope someone has had some dealing with as i cant really afford to go to the dealers the fault is displayed on the dash when the brake pedal is pressed.

I bought a code reader and this is what the codes said
4404 The CAN signal from component S9/1 (Stop lamp switch) of the traction system is implausible
4600 The voltage supply of circuit 87 has undervoltage
4602 the voltage supply of the valves is faulty.

I changed the brake switch it had no effect!!

Pls Help
Andy
The rear SAM may be faulty, check for condensation in the boot.

E420 '93
240D '82 "The wheel"
200E '91
230E '83 "archaeological effect"
Contra verbosus noli contendere verbis, sermo datur cunctis, animi sapientia paucis.

Mercedes technician 20 years fixing Mercedes.
daddi is offline  
post #10 of 12 (permalink) Old 04-29-2009, 06:10 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by daddi View Post
The rear SAM may be faulty, check for condensation in the boot.
What is the SAM please? Condensation is the probable cause of the faulty bulb sockets too, if I'm not mistaken.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Brake Pad light & brake light - not the usual Stitch W163 M-Class 11 11-21-2008 10:28 AM
    Fault light benzhead R170 SLK-Class 3 03-08-2007 05:58 PM
    Brake fault code C1330 Chris1501 W203 C-Class 0 11-12-2006 10:15 AM
    Brake Pad Light & Parking Brake light come on when Complete Stop Yianni General Mercedes-Benz 1 04-02-2006 09:42 AM
    Brake Pad Light & Emergency Brake Light Come on when I come to stop Yianni General Mercedes-Benz 3 03-29-2006 10:57 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome