New user - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-27-2009, 01:24 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2009
Vehicle: W124 230 E
Location: Cape Town
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New user

after our car was stolen on 15 March 2009, my aunt loaned us her W124 230 E, and now i need to fix all it's electrical faults etc...
ashfaak is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    New User victor98 General Mercedes-Benz 2 07-20-2007 10:00 AM
    new user here!! kevinajones22 W203 C-Class 5 01-20-2006 12:50 AM
    A new user toni.f1 W201 190-Class 3 04-30-2004 12:16 PM
    new user jol W203 C-Class 1 01-12-2004 03:08 PM
    NEW USER GARYB W203 C-Class 2 01-12-2004 01:38 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome