convert top system not operating on SL - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-26-2009, 09:26 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2009
Vehicle: 1997 SL320, 2003 S430-4
Location: NJ countryside
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
convert top system not operating on SL

my 1997 SL320, after storage and charging the battery the convertable top button and rollbar switch stay lit but will not function. i reset the windows and checked the fuses.. i removed the hardtop and raised the softtop manually to see of a relay was stuck.. still the same. upon activating the button i hear a pump or motor sound for a few seconds but nothing happens. could this be a 'low fluid' or a code issue?
poppopscar is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-26-2009, 10:29 PM
BenzWorld Elite
 
GogglesPisano764's Avatar
 
Date registered: Feb 2008
Vehicle: 1983 300D Turbo Diesel
Location: Brewster,NY (Putnam County)
Posts: 1,799
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to GogglesPisano764
Welcome to Benzworld!! Sorry to hear youre having issues with your Benz. you can try using the search part of the forums to see if someone may have had a similar issue and resolved it, or you can post your question directly in the R129 section of the forums. I'm sure one of the members in that section would be glad to help!

Yes Honey! Thats how they sound! Its a diesel!
MBCA Member
1983 300D "Schultz" (Relocated to Canada)
1983 300D "Klaudia" (My new love)
1985 300D (Whipped then Stripped)
1985 300SD (In way over my head and let go)
2002 Suburban Z71 (Eats gas stations during trips)
2004 Aveo (Only because I enjoy stuffing my fat ass in a tiny car. Oh and it gets good gas mileage)
GogglesPisano764 is offline  
post #3 of 3 (permalink) Old 08-08-2009, 03:56 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    comand operating system bjanko Audio & Telematics Forum 6 03-09-2011 07:58 PM
    1996 Soft Top & Roll-Over Bar not Operating elzorro21 R129 SL-Class 10 10-15-2007 10:23 AM
    COMAND System Operating Instructions- Where are they found? enniplace R171 SLK-Class 4 01-09-2005 04:58 AM
    The ML security system - operating information and a question: Darkmann W163 M-Class 3 06-09-2004 07:42 PM
    Coolant System Flush possible? and A/C System rechange/convert? vissjb W126 S,SE,SEC,SEL,SD,SDL Class 0 05-20-2003 10:19 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome