New Member, 2000 E320 - P0300 +++ Codes - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-09-2009, 06:40 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2009
Vehicle: 2000 E320 Wagon 2wd, 162,000 miles (original rear cats changed at 162k)
Location: Bloomfield Hills MI
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New Member, 2000 E320 - P0300 +++ Codes

Hi, and thanks for any advise you can provide...

I do most mechanical work myself on my "german" cars, and have owned my 2000 E320 for 2 years now. I've changed the Crank Position Sensor, front springs, one HID bulb and ignition switch (dealer did that).

This is a "Michigan Car" with lots of rust on it, and I'm getting ready to do some body work.

I bought the car with 130k miles on it, and now have 153k miles on it.

I've seen a lot of treads with postings of errors, as I was driving my car last weekend, all was well, and all of a sudden after giving it a bit more gas to accelerate, the CEL came on and I lost 80% of my power. Limpped home, plugged in my OBDII and got a ton if misfire errors P0301, p0303, p0302, p0300Pd, etc. Tested the MAF, and since I saw a lot of high failures of this item on the thread, changed it with no luck.

Any suggestions are welcome... thanks for your help!
jack007 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    ML320 P0300,P0304,P0305 codes RobSmith W163 M-Class 6 05-22-2009 03:45 AM
    Codes P0300, 0302, 0700 '99 ML430 ReBell W163 M-Class 0 12-06-2008 07:23 AM
    Getting Codes P0300 and P0307 JamesBahn W140 S-Class 5 10-18-2007 08:03 PM
    99 E320 P0300 etc codes (not MAF?) fourflattires W210 E-Class 9 09-01-2007 08:38 AM
    P0300, P0301-P0306 and P0170 codes Brapol W140 S-Class 2 06-03-2006 11:01 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome