2003 ML350 heat problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-06-2009, 12:56 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2009
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 2003 ML350 heat problem

Hi all , I'm new here but I really like what this site does. After changing my Crankshaft position sensor last week, I vowed never to let the dealer touch my car again. It cost me $75 and a half hour to replace. My dealer wanted around $400 for the job. 2 bolts and I didn't even get my hands dirty.

I have a problem with my blend air door. I can reach through (after taking glove box out) and move it manualy. It changes from warm air to cool. Of course I'm hoping to not take the dash out so...I was wondering if there is any kind of "brain" that might be bad that is before the stepper motor.

I get blower control
I don't get temp control
I don't get vent control...bottom-middle-defrost. Is there another door for this?
I was thinking if both doors are inop then it might be something else.
Thanks,
Dave
dhalcomb is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-06-2009, 09:50 PM
BenzWorld Elite
 
GogglesPisano764's Avatar
 
Date registered: Feb 2008
Vehicle: 1983 300D Turbo Diesel
Location: Brewster,NY (Putnam County)
Posts: 1,799
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to GogglesPisano764
Welcome to Benzworld!! Try posting your question in the forum specific to your car or you can try the search method and I'm sure that one of the many knowledgable members here would be glad to help you!

Yes Honey! Thats how they sound! Its a diesel!
MBCA Member
1983 300D "Schultz" (Relocated to Canada)
1983 300D "Klaudia" (My new love)
1985 300D (Whipped then Stripped)
1985 300SD (In way over my head and let go)
2002 Suburban Z71 (Eats gas stations during trips)
2004 Aveo (Only because I enjoy stuffing my fat ass in a tiny car. Oh and it gets good gas mileage)
GogglesPisano764 is offline  
post #3 of 3 (permalink) Old 04-06-2009, 11:25 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2009
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks so much!
Dave
dhalcomb is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Need help with 2003 ML350 CD Changer problem "Mag Empty" CHollett Audio & Telematics Forum 10 12-30-2008 07:51 PM
    2003 ML350 - odd starting problem rangai W163 M-Class 6 02-28-2008 10:50 AM
    2003 ML350 NAV problem S4toML W163 M-Class 0 07-26-2007 01:29 PM
    FS: 2003 Ml350 gperlow For Sale/Wanted/Trade/Giveaway 0 05-21-2007 06:20 AM
    2003 ML350 with Hesitation Problem: Have you experienced this? Please post here if yes S4toML W163 M-Class 7 01-16-2004 10:38 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome