W211 E270 CDI, 2004 Heater problem Solved - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-27-2009, 10:49 AM Thread Starter
BenzWorld Newbie
Date registered: Feb 2005
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to piksend
(Thread Starter)
Cool W211 E270 CDI, 2004 Heater problem Solved

Hi folks, heater on my W211 kept blowing cold air even when settings were at max heat. Sometimes fault would cure it'self till it failed permanently.
THis is how I solved the problem: Found a 4-way motorised valve right under the brake-servo/master cylinder assembly had ceased, due to corrosion on motor:-looked like coolant fluid found it's way into the motor's chamber. This is quite a difficult part to access and change, so allow up to 4 hours to do the job. Had to do the following:
1. Disconnect battery- A MUST
2. Disconnect all control modules and fuse panel on the left hand side of the engine compartment. Remember to mark connector positions
3. Remove the housing for the 3 control modules, taking care not to snap any cables.
4. You can now view the 4-way valve right under the brake-servo assembly.
5. Cover all the cable connectors with a lage towel.
5. Push back 3 metal clips on the valve to release 3 of the pipes. (a little coolant fuid will leak, hence the need to cover the cable connectors)
6. 4th pipe will require use of pliers to release the horse clip.
7. Fit new motorised valve & the rest in reverse order, making sure all connectors have fitted tightly. Battery connection is the LAST step.
8. Top up lost coolant
9. Test run & you should be smiling, well at least I was, and I saved £450!
piksend is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-27-2009, 12:02 PM
BenzWorld Elite
Diesel Benz's Avatar
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,320
Mentioned: 3 Post(s)
Quoted: 32 Post(s)
Diesel Benz is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Need Help: E270 CDI Turbo Problem gka W211 E-Class 19 04-30-2015 05:55 AM
    No Heater/Aircond/Blower -Nothing-Problem solved- Merc-S600 W140 S-Class 0 12-15-2008 10:01 PM
    Exhaust system problem solved, now onto Heater motor noise! will3hawks2 W124 E,CE,D,TD Class 0 02-27-2005 05:38 AM
    Exhaust system problem solved, now onto Heater motor noise! will3hawks2 W124 E,CE,D,TD Class 0 02-27-2005 05:38 AM
    E270 Cdi - engine management problem delays delivery marc777 W211 E-Class 4 10-23-2002 01:36 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome