98 ML 320 Bad ECU, would a used one work? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-24-2009, 05:09 PM Thread Starter
BenzWorld Newbie
Date registered: Mar 2009
Vehicle: 1998 ML 320
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy 98 ML 320 Bad ECU, would a used one work?

Hi everyone, I am new to this, and have a very bad problem. My dad purchased an ML 320 to sell it in Mexico. One day before taking it to Mexico City, the ECU seemed to have gone wrong. At least I think it's that, because I have read some forums with the same problems and that seems to be the problem. What happens is this:

First, the car wouldnt star what so ever, you would turn the key and no sounds would be made, anything. A mechanic came to the house, checked it, when he plugged his scanner, it started. It has started since all the time, but now the trans is not shifting gears. On the scanner, the message "no communication between engine and transmission" appears. Thats what the mechanic told me. When you drive the car, the speedometer does not work, it drives but only fist gear and reverse. The check engine light came on. I really don't know what it could be. At the dealership they say they need to change the speed sensors on the wheels, change the ecu, change some other modules, etc. I am really hoping someone here has the expertise to help me. I bouth a used ECU, and at the dealership they say I need to buy a new one, since the codes won't work for this car. I just leave it open for anyone to help, appreciate it guys.
Mikealvarez is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Symptoms/Problems due to bad ECU/ECM? chrisdpham W124 E,CE,D,TD Class 4 09-18-2011 02:06 PM
    Fan always at full, bad ECU???? motoadve W203 C-Class 1 02-05-2008 01:17 AM
    5th gear and ECU work together sjdavis83 W140 S-Class 2 10-09-2007 11:51 PM
    Performance ECU Chip - Good or Bad ? GODZILLA W140 S-Class 3 06-10-2005 01:02 PM
    Will an slk 320 eisenmann exhuast work on my clk 320? Same year too. bib C208/A208 CLK-Class 0 12-13-2001 07:51 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome