My mysterious problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-23-2009, 11:09 AM Thread Starter
BenzWorld Junior Member
Date registered: Nov 2008
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
My mysterious problem


I have a 2000 E430 with a mysterious behavior. After a suspension alignment the steering wheel will be straight as the car tracks straight...everything fine....until I rotate the tires. The car will still track straight but the steering wheel is no longer perfectly level...currently slanted slightly to the right. No real problems but it drives me crazy as I'm always looking at it! This behavior has been consistent even through a new set of tires and different brand. Also the problem occurs whether I swap the tires front to back & right to left or simply front to back. What could be happening?????

Thanks, Matt
mditka85 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1997 E300 TD Engine Mysterious Misfire problem after overnight rest... can you help? mebobster W210 E-Class 7 03-31-2008 02:29 PM
    mysterious problem aucaster W126 S,SE,SEC,SEL,SD,SDL Class 0 11-11-2005 02:35 PM
    Mysterious Overheating Problem - 300D szv6y0 W123 E,CE,D,CD,TD,TE Class 4 06-24-2004 09:32 PM
    mysterious problem on 300E, dealer can't fix Guest (MBNZ) W124 E,CE,D,TD Class 7 04-18-2002 06:12 PM
    Mysterious problem - heating system goes to crazy Ronbo R170 SLK-Class 3 11-29-2001 06:55 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome