Won't start - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-22-2009, 09:10 AM Thread Starter
BenzWorld Newbie
Date registered: Mar 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Won't start

i have 2001 ML-320 that i have to jump start. the lights and horn blows this is the second time it has happen don't know if it is the alternator or the battery i'am confused:. The battery is the orignal battery that came with the vehicle
baddone is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-22-2009, 09:29 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
It's probably the battery but I'd take it to an Auto Zone (or similar place) and they can check that and the alternator for free.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    HELP! S-320 will not start! but finally got to start with direct power to starter Newinport W140 S-Class 12 07-23-2013 12:49 PM
    1995 e320 Wagon - AC fails first start, fine on second start bwcole W124 E,CE,D,TD Class 3 05-18-2008 09:54 PM
    sl500 cold start fine-short trip park restart rough idle hard start?? dpol1835 R129 SL-Class 7 01-02-2006 06:33 AM
    Hard start or second start when warm high hc level-- beware major expense Peter Seow W126 S,SE,SEC,SEL,SD,SDL Class 1 07-03-2004 06:23 PM
    Should my 1989 190e start in 2nd gear unless floor it from start? Guest (MBNZ) W201 190-Class 5 08-01-2002 12:27 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome