NorthWest 2000 S430 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-21-2009, 10:56 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 2000 S430
Location: Lynnwood WA
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool NorthWest 2000 S430

I would like to say hello and thank you for all future input and advice.


2000 S430 Desert Silver with sport package. I bought this car in Sept. of 07 with 27,000 miles and in perfect condition. The car came from a Nike executive that only drove it to and from the airport when picking up clients.

This is the history from the day I got it:

After about 3 weeks the airmatic warning would come up and say visit workshop. This would not happen all the time and the car seem to be riding good. It does have AMG wheels on it and for some reason if I hit a dip the left rear tire will rub on the wheel well and make a noise. I check the tire for damage and there is hardly and digs into the tire. Sometime when parking out front of my house, which has a slight slope, the car would settle with the left side really low and right side normal or a little high. Took it into the shop and they found the speed sensor was bad on the airmatic system. I had it replace and have no gotten that error message since but the left tire will still rub every once and a while.

I tried to put a set of Eagle Eyes head lamps and they looked great but did not always work and I also received error messages so I put the stock light back in.

A few months later the passenger door stopped working completely. Took it to Phil Smart MB dearler here in Seattle. They had to replace the door modual then it worked fine. While at the shop the steering wheel adjustment motor went out so I had them replace it also. At this time all service bullitin work was completed. Not long after this did my wipers start acting up and turning on even when it was not wet. I took it in and no issues were found.

Next came the car would not open with the keyless entry system and I had to use the manual key to get in. I then discovered how to reset the keyless system by using the manual key in the trunk. Everything was back to normal.

The break pad warning light came on so I went and got new breakpads and installed the front set with no issues but I need to find new break sensors to replace the old ones. I still get the warning but that is due to the fact the break sensor that went off has not been replaced yet. If someone knows were to get them cheep please let me know. The back breaks still have 40% to go.

The lastest issues are posted here:http://www.benzworld.org/forums/w220...ers-radio.html.

Here is the link to see a picture: BenzWorld Image Gallery - 2000 S430 from NWS430

I really enjoy my car. I drive from Seattle to Montana twice a year and I have never had a car that at the end of my 8 hour trip not feel tired except for this one. This car is a dream to drive on the road. In Montana I90 has alot of whindy sections and I put this baby in sport mode and fly by everyone and the car doesn't even budge. It sticks to the road like glue. Even with all the little issues I don't think I would drive anything less than an S going forward.

Glad to be here,

Paul
NWS430 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-21-2009, 05:00 PM
slightly creased
 
420 SE's Avatar
 
Date registered: Sep 2005
Vehicle: 1988 420 SE; 2015 ML 400
Location: Gold Coast, QLD, AUS & Doha, Qatar
Posts: 16,175
Mentioned: 1 Post(s)
Quoted: 135 Post(s)
Lifetime Premium Member
Welcome to the forum. You will find tech help in the model specific pages.

Ross

OzBenz

beware of fundamentalists

420 SE is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Thinking about purchasing a USED 2000 S430, what options should I look for, any problems w/ 2000?... Guest (MBNZ) W220 S-Class 10 04-18-2008 10:14 AM
    2000 s430, What to look out for? 500ezin W220 S-Class 8 02-23-2008 06:50 PM
    2000 S430 Heavyd W220 S-Class 12 04-02-2007 12:03 AM
    2000 S430 makkhichoos General Mercedes-Benz 4 12-14-2005 07:00 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome