A/C-Heater Problem with my "new" 420s - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-15-2009, 10:21 PM Thread Starter
BenzWorld Junior Member
Date registered: Sep 2007
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
A/C-Heater Problem with my "new" 420s


The heat in my "new" 1997 420s with 135,000 miles blows hot on the passenger side, but blows cold on the drivers side. If you turn on the defrost it does the same thing...the passenger side of the window clears up, but the drivers side does not.
Where could be causing this?

Thanks, Les Marietta GA
LesG is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    "Buzz Saw" sound when turning left from heater A/C blower / fan motor kevinj R129 SL-Class 52 12-26-2009 10:02 AM
    What (where) is "Auxilary heater"? samosali W140 S-Class 11 01-12-2009 12:25 PM
    Clinton Advisor: Indianans "Shit", "Worthless White N*rs", Indiana Primary Next Week. Jakarta Expat Off-Topic 4 05-02-2008 02:07 PM
    "Hot Water Heater" is another pet peeve of mine. Digmenow R/C107 SL/SLC Class 6 02-14-2007 03:37 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome