transmission problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-15-2009, 05:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
transmission problem

I am new to this site. I drive a E320 and my son has been driving a 98 ml320. A few weeks ago he started to lose power as he was driving and the speed would decrease. Dealership replaced a sensor but shifting problems continued. This week, he felt like he had hit a bump. As he slowed he heard a grinding noise, like if your brakes pads were totally worn. He slowed the car and stopped. When he started it again, it would not move. Does he need to replace his transmission?
nankry is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Problem with transmission Lillie W220 S-Class 10 03-11-2009 06:34 AM
82 Transmission PROBLEM 82 benz W123 E,CE,D,CD,TD,TE Class 2 11-06-2008 11:51 AM
Transmission Problem roypaul W210 E-Class 0 09-30-2008 01:44 AM
Transmission problem jwht W126 S,SE,SEC,SEL,SD,SDL Class 5 11-04-2007 10:28 PM
Brake padal vibration problem + transmission problem Majid Mansoori W210 E-Class 11 09-22-2003 07:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome