1st Time Mercedes owner '87 300SDL - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-12-2009, 11:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 1987 Mercedes Benz 300 SDL
Location: California
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1st Time Mercedes owner '87 300SDL

Hello everyone. I just bought an '87 300SDL with 288K miles on it 3/7/09. Extremely clean and has been taken care of and has been in a garage over most of its life. I am the third owner. It has the original owners manual in the glove box and maintenance records from 0 to approx. 186K, then picked up gain at 243K miles. I do not have anything for maintenance in between those miles. Let me tell you the "Good, the Bad, and the "Ugly".

The Good: Zero rust anywhere; Engine does not smoke even from a cold start and is extrememly clean for a diesel. The "trap" has been removed and recall properly done. No tears anywhere in the interior and back seat looks like no one has ever sat in it. No spots on the carpet, interior is 99% new looking.

The Bad: The vehicle has three small door dings, crack in front bumper about 8 inches long running horizontally; sun-roof will not open; antenna will not raise; left rear passenger window rolls down but will not roll up.

The Ugly: Most of the time the car will not start when turning it to the start postion. I have to keep trying it over and over again (like 12 times)before it finally will kick in the starter and start up. I have already had to call AAA once to bail me out. Also, I have never seen an ignition switch that once you release to the "Run" position, you cannot turn turn it back to "start". I have to completely turn off the key and then return to the glow position, wait, then "start". A real pain.

Question: Is it the starter safety switch on the tranny that "thinks" it is still in gear, or is it the ignition switch, or something else. The battery is 100%, so that is not the issue.

Help please! Thank you.

Brad
Bradford Whitty is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-12-2009, 12:12 PM
BenzWorld Elite
 
kodiakj2's Avatar
 
Date registered: Jun 2006
Vehicle: '84 500 SEC Euro 040 black Lorinser 2005 sl500
Location: SoCal
Posts: 2,518
Mentioned: 0 Post(s)
Quoted: 11 Post(s)
Welcome Brad!
You will find a large group of very knowledgeable members down in the w126 section of this forum. You will also get a ton of information from searching the w126 forum with regards to your starting issues.

Sounds like you have a good daily driver once the little things get sorted out. As far as your starting problem, I had the same gremlins when trying to start my SEC. Changed out the neutral safety switch and have yet to have another problem with it. Try starting your car in neutral the next time this happens. Usually the switch will not go out all at once, but rather become an issue a little at a time. If it starts in neutral, but not park, I would say change your neutral safety switch. There are also small plastic bushings that keep the gear selector aligned. If the bushings deteriate you may also have the same symtoms, however your gear selector will also feel "sloppy" and not stay perfectly where it should.

See you in the w126 section,
Greg
kodiakj2 is offline  
post #3 of 4 (permalink) Old 03-12-2009, 01:20 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 1987 Mercedes Benz 300 SDL
Location: California
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
300 SDL Problem

Thank you Greg for the quick input! Yes, the shifter does feel a little sloppy, so checking out the plastic alignment bushings will be my first stop. i have tried it in neutral the past few days, including this morning, but still will not start. I will get under it this weekend and take a look. First, I need to find a nice repair manual and I see that Haynes and Chilton's does not have one, whihc is OK, as they are not great anyway. I usually purchase a Haynes or Chilton's, plus a factory manual, so I have one "easy to read" versus the reall technical aspect.

Thanks again Greg, see in the W126 section.

Brad
Bradford Whitty is offline  
post #4 of 4 (permalink) Old 03-12-2009, 04:30 PM
BenzWorld Member
 
christopher1959's Avatar
 
Date registered: Jul 2007
Vehicle: 1990 Mercedes 300TE Estate Wagon 3.0L 208K miles Smoke Silver/Cream Beige Tex. and others.
Location: Sunny Memphis TN USA
Posts: 166
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hey, your ignition switch is made to not restart until you turn it back off, keeps you from grinding the starter into the flywheel if it is running. All MB's were made like that, But you could have a failing electrical portion of the ign. switch, on the back side of the ignition switch, it can be replaced by itself, with out the key cylinder. Have you tried putting pressure on the key and moving it around while at the same time holding it in the start position?. But the Best bet is the neutral safety switch is failing..as mentioned by Greg, and the best aftermarket manuals IMHO are made by Bentley publishing,, if you dont have the factory set... good luck.

1990 S-124 3.0 Sport Touring Wagen. 218K + Miles
1987 Porsche 911 Carrera 3.2 53K miles !
1971 BMW 2002
1987 BMW 325 IS M-tech
1976 Jaguar XJ12C 5.3 V12 Coupe
2009 Suzuki GZ250
And Remember to always KISS, Keep It Simple Stupid!
christopher1959 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Hello from 1st time Benz Owner abarada General Mercedes-Benz 4 08-29-2009 09:20 PM
    1st time Member 2nd Time owner DGB190E General Mercedes-Benz 0 10-03-2008 10:38 AM
    1st TIME Mercedes-Benz owner! ISO Advice (1994 E320) TMaticE320 W124 E,CE,D,TD Class 12 04-28-2006 08:41 AM
    1st time Benz owner gdestiny W211 E-Class 1 04-04-2005 12:15 PM
    1st Time Owner - question on Tires baijon R170 SLK-Class 4 04-29-2003 05:18 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome