low rpm '99 s420 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-01-2009, 09:03 AM Thread Starter
BenzWorld Junior Member
Date registered: Jul 2005
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Red face low rpm '99 s420

Hi Guys,

I've been a member a long time but never got around to posting. Anyway I have a "99 s 420 with 68K onit. I just had engine mounts put in. Now when I stop for a light or idle in gear I feel a vibration in the steering wheel. The mechanic said the rpms are about 100 or so too low. I can agree since when I put it in neutral the rpms pick up and there is no vibration. What do I do. Can I fix this myself? Maybe I need new plugs, I think these are the originals???
I bought the car with 34K. Worst car I have ever owned. My '91 560 SEL was far superior.
tellis1112 is offline  
Sponsored Links
post #2 of 4 (permalink) Old 03-01-2009, 09:46 AM
BenzWorld Elite
ohlord's Avatar
Date registered: May 2007
Vehicle: 1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Location: North of Raymond
Posts: 6,019
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Visit the

w140 section in the forum or on MBWorld.org Mercedes Benz Enthusiast Community
Fire your mechanic,if he can't locate an idle condition.Either change the plugs yourself.Diy article on MercedesShop - Mercedes Benz Parts and Technical Information or find an mb indie shop in your area that can scan the car on a star diagnostic scanner and locate the problem.
The guy is a goof ball.M119 engines are great in the right hands and when sorted out you will be happy with the car.

00-02 drivers side self dimming heated mirror
17mm special spark boot tool
O2 plug and play sensors
16mm spring loaded swivel spark socket
trans dipstick and magnet

Mercedes Benz Lyrics
Artist(Band):Janis Joplin
"Oh Lord, won't you buy me
a Mercedes Benz"
"Follow Peace,center Life"
ohlord is offline  
post #3 of 4 (permalink) Old 09-06-2009, 06:28 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
post #4 of 4 (permalink) Old 09-07-2009, 02:44 AM
BenzWorld Junior Member
Date registered: Sep 2009
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Instead of fixing of your self, I think you should go to the local body shop in order to avoid risk.
jenifer.kaif is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    500 Low RPM ?? xctguy W210 E-Class 10 06-13-2009 11:04 PM
    still low power on low RPM Molotov W201 190-Class 0 08-18-2008 04:03 PM
    Low RPM zd123 W126 S,SE,SEC,SEL,SD,SDL Class 2 07-04-2008 11:49 PM
    Low RPM miss AlaRonnie R/C107 SL/SLC Class 46 07-15-2007 01:24 PM
    Help !!! my rpm is running low Guest (MBNZ) W124 E,CE,D,TD Class 3 05-22-2002 03:30 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome