Hello from Brisbane Australia - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-26-2009, 04:31 PM Thread Starter
BenzWorld Junior Member
 
Simo69's Avatar
 
Date registered: Feb 2009
Vehicle: W124 E220, W126 380 SEL, W202 C280 Sport AMG (sold),W123 240D, W123 250, W124 300 E 24v Sportline, W
Location: Brisbane, Australia
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Red face Hello from Brisbane Australia

My name is Simon. I have three benz's currently and my partner another two. Mine are a mint '95 W124 E 220, a rough W126 380 SEL just purchased for 500 bucks that I am about to play with and my daily driver, a 96 W202 C280 Sport AMG which i am informed by MB Brisbane was the clerk of course car for the 96 Indy car race on the Gold Coast. This would seem to be the case, though I can't confirm it, by the extra fuse card in the fuse holder in the boot(trunk) hooked up for the fire extinguisher system, strobes and a number of other cool things that are no longer part of the car.

I have often browsed this site and found it useful, friendly and informative. I wish I could say that I have joined it out of the overwhelming sense of fellowship, but unfortunately I have an ulterior motive. I need assistance with my daily driver, the C280. It's gearbox. My problem is not described in any of the threads on the forum.

My box has no kickdown. If you leave it in drive from a standstill it will hold first gear for about a second, second for about a second then into third and straight into fourth. All of this done by about 30 KPH on the clock. If I don't manually shift it , it will stay in fourth. First gear, as you know cannot be selected on the gear quadrant but relies upon the magic of the box to select it if you either kickdown the switch on the floor or else select S at the lights/low speed. I need to say that if I select S at the lights I will get first (and can feel it drop into first on slowing to a stop) but it changes into second very quickly and then I can hold second third and fourth all the way to redline. Second to third manually held and changed will change in the normal way ie a slight delay as the box deals with the change and completely like every other benz I have ever had. third to fourth it goes straight in and roughly comes straight out with zero delay. There is no slipping on any change. It has been like this now for seven months. No one can give me an answer except that the box needs replacing at a cost of 5500 or more. It has had a service, after the problem began. One of the looms to the box is corroded under the car and devoid of coating. there are two looms to the box, one is the selector illuniation loom replaced already and the other, we don't now what it does. They keep saying it's electronic. I keep saying this is not an electronic box it's mechanical. I am about to lose my mind.

I am at a loss and ready to dump the car. Any suggestions as I dearly love the car but will toss it to the wreckers otherwise as I have had enough of being buggered around to no solution.

Yours faithfully
Simon.
Simo69 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-26-2009, 06:30 PM
BenzWorld Elite
 
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld
livefreeordie is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Any members in Brisbane - Australia? Finny64 General Mercedes-Benz 1 03-24-2014 08:27 PM
    Brisbane Australia Vito people Mover connexor General Mercedes-Benz 0 10-03-2008 04:27 PM
    Hi from Australia BrettML320 W163 M-Class 11 12-18-2007 09:56 AM
    Any one from Brisbane!! Jedland79 General Mercedes-Benz 4 10-11-2006 03:45 AM
    brisbane sighting ramona W201 190-Class 0 12-13-2004 06:00 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome