Accelerator Sensor - Where can I get one? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-26-2009, 07:01 AM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2007
Vehicle: 1998 C43 AMG
Location: Bmore
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to MDamg
(Thread Starter)
Question Accelerator Sensor - Where can I get one?

I have a 98 c43 amg. I have been having a throttle issue, and based on the symptoms, I believe it is the Accelerator Sensor.

Q: Is this a DIY project?
Q: Where can I get one?

The symptoms: After hard acceleration, the car goes into some sort of safety mode. The throttle/acceleration is very slow - however, it resets itself when you turn the car off and back on.

Any help is appreciated.
MDamg is offline  
Sponsored Links
post #2 of 4 (permalink) Old 02-26-2009, 07:16 AM
Administratoris Emeritus
GeeS's Avatar
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,831
Mentioned: 1 Post(s)
Quoted: 544 Post(s)
I don't ever recall selling one, it's not a common failure.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #3 of 4 (permalink) Old 02-26-2009, 08:20 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,526
Mentioned: 9 Post(s)
Quoted: 1068 Post(s)
When I called you GS for Pedal Position Sensor for my 97 E class you didn't have one.
In my car it was placed next to brake booster. Some cars have it build in the pedal.
It is just big potentiometer mounted with couple of small bolts, plug and linkage.
I bought mine at Duval.
Kajtek1 is online now  
post #4 of 4 (permalink) Old 02-26-2009, 09:36 AM
BenzWorld Elite
Date registered: Dec 2002
Vehicle: 92 500SEL to 01 E320T current 2014 lexus LS460
Location: Florida
Posts: 3,886
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
I went thru it, car shifts fine untill you down shift, then it is limp home mode. Its a probably a MB item, sits up there next to the shock/brake booster, has a bowden cable going to it
012-542-33-17 on my 01E
Peter Guenther is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    TPS or Accelerator Position Sensor hhrahman77 W210 E-Class 7 12-14-2014 10:57 AM
    Which O2 sensor? P0136 O2 Sensor Circuit Malfunction (Bank 1 Sensor 2) ClkE C208/A208 CLK-Class 3 05-16-2008 04:44 PM
    accelerator Hemersam W116 S, SE, SEL, SD Class 1 04-30-2008 09:54 AM
    Accelerator mssdoglover W126 S,SE,SEC,SEL,SD,SDL Class 4 10-19-2006 07:22 AM
    accelerator benzito333 W211 E-Class 1 01-16-2004 07:12 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome